summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..f77495e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+
+DESTDIR ?=
+PREFIX ?= /usr
+DEST = $(DESTDIR)$(PREFIX)
+
+all: docbuild
+ $(MAKE) -C po
+
+docbuild:
+ po4a-build
+
+install:
+ $(MAKE) -C po install DESTDIR=../debian/multistrap
+
+clean:
+ $(RM) *~
+ $(MAKE) -C doc clean
+ $(MAKE) -C po clean
+ $(RM) po/*.gmo po/*.mo
+
+# adds the POT file to the source tarball
+native-dist: Makefile
+ po4a-build --pot-only
+ $(MAKE) -C po pot