summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-08-31 14:06:03 -0700
committerJoey Hess <joey@kitenet.net>2014-08-31 14:06:03 -0700
commit2a044e2dcc3efcaa6ba8f0d7b6f8bc68f13ee3a3 (patch)
tree461abf31d5233e80cb705e618e3259249d1e9f70
parent68c9ac23f6812644cafcd88cbdc8f9dfdcdc73df (diff)
Fix breakage introduced by --minimal patch.debian/1.20140831.1
-rw-r--r--debian/changelog6
-rwxr-xr-xmr4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 4634b80..4e6d878 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+myrepos (1.20140831.1) unstable; urgency=medium
+
+ * Fix breakage introduced by --minimal patch.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 31 Aug 2014 14:05:56 -0700
+
myrepos (1.20140831) unstable; urgency=medium
* Deal with abs_path change in new version of perl, now it returns undefined
diff --git a/mr b/mr
index 98e080c..d8a27b2 100755
--- a/mr
+++ b/mr
@@ -853,7 +853,7 @@ sub action {
}
print "$actionmsg\n" unless $quiet || $minimal;
- my $hookret=hook("pre_$action", $topdir, $subdir);
+ my ($hookret, $hook_out)=hook("pre_$action", $topdir, $subdir);
return $hookret if $hookret != OK;
my ($ret, $out)=runsh $action, $topdir, $subdir,
@@ -908,7 +908,7 @@ sub action {
return FAILED;
}
}
- my $ret=hook("fixups", $topdir, $subdir);
+ my ($ret, $hook_out)=hook("fixups", $topdir, $subdir);
return $ret if $ret != OK;
}