summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew Shadura <bugzilla@tut.by>2012-08-15 22:21:29 +0200
committerAndrew Shadura <bugzilla@tut.by>2012-08-15 22:21:29 +0200
commit741f3e4371c794ae89af77131280533e559bbe35 (patch)
tree61ccd858d07b1fc21a4b73749063cd164ca546a9 /debian/rules
parent02bc804b997f43ea112002310775e3238d218992 (diff)
Use short form of dh9.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules64
1 files changed, 2 insertions, 62 deletions
diff --git a/debian/rules b/debian/rules
index 6424430..2d33f6a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,64 +1,4 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-configure-stamp:
- dh_testdir
-
- touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp
- dh_testdir
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/nat-traverse.
- install -m 755 nat-traverse debian/nat-traverse/usr/bin/
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installman nat-traverse.1
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+ dh $@