summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2019-09-07 22:04:19 -0400
committerAaron M. Ucko <ucko@debian.org>2019-09-07 22:06:30 -0400
commit527058fbbae83c52804b7ff8ba52d5958e79139f (patch)
tree2e6ff2a516e899ad50681cc1830862d686cd29e3
parentb9b78291362d617c68b2d82220a5c044b21013db (diff)
Give ncbi-cn3d a binary-specific version, missed earlier.
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules10
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 16a6f24a..7b6c4f2f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,9 @@ ncbi-tools6 (6.1.20170106+dfsg1-5) UNRELEASED; urgency=medium
debian/upstream/metadata accordingly. (Originally done in
6.1.20170106-7, but reverted in 6.1.20170106+dfsg1-1 to avoid holding
up DFSG fixes.)
+ * Give ncbi-cn3d a binary-specific version, missed earlier.
- -- Aaron M. Ucko <ucko@debian.org> Sat, 07 Sep 2019 21:56:06 -0400
+ -- Aaron M. Ucko <ucko@debian.org> Sat, 07 Sep 2019 22:04:18 -0400
ncbi-tools6 (6.1.20170106+dfsg1-4) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index 059a57b1..f3f50aa0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,8 +8,14 @@ export NCBI_VERSION_DATE =$(word 3, $(subst ., ,$(NCBI_VERSION)))
export NCBI_VERSION_DEBREL=$(word 2, $(subst -, ,$(NCBI_VERSION_FULL)))
export NCBI_VERSION_SHLIB=$(NCBI_VERSION:%+dfsg1=%)
+export CN3D_VERSION=$(shell sed -ne 's/.*Version \([1-9][0-9.]*\).*/\1/p' \
+ cn3d/cn3dwin.c | head -n1)
+export CN3D_VERSION_DATED=$(CN3D_VERSION).$(NCBI_VERSION_DATE)
+export CN3D_VERSION_FULL=$(CN3D_VERSION_DATED)-$(NCBI_VERSION_DEBREL)
+
testversions:
env | fgrep NCBI_VERSION
+ env | fgrep CN3D_VERSION
# Set these here, rather than using the csh hackage that passes for an
# upstream build system. Mostly taken from ../platform/{ppc,}linux.ncbi.mk.
@@ -219,6 +225,10 @@ endif
override_dh_makeshlibs-arch:
dh_makeshlibs -V
+override_dh_gencontrol-arch:
+ dh_gencontrol -pncbi-cn3d -- -v$(CN3D_VERSION_FULL)
+ dh_gencontrol -Nncbi-cn3d
+
override_dh_builddeb:
dh_builddeb -pncbi-rrna-data -- -Zxz -z7 -Sextreme
dh_builddeb -Nncbi-rrna-data