summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorKexy Biscuit <kexybiscuit@outlook.com>2019-10-03 04:37:18 +0800
committerMathieu Trudel-Lapierre <mathieu.trudel-lapierre@canonical.com>2019-10-02 16:37:18 -0400
commit43d80a655a450b9855b14477f1c921e5ebc05281 (patch)
tree465aaa4d6f2f83cb0d1edccd3757d968a364e0b6 /Makefile
parent521a69554d2c29df7e9674ec874d5a29a13b9fdd (diff)
Makefile: fix escaping in _features.h (#103)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d89eb26..c9921ed 100644
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,7 @@ netplan-dbus: src/dbus.c src/_features.h
$(CC) $(BUILDFLAGS) $(CFLAGS) -o $@ $^ `pkg-config --cflags --libs libsystemd glib-2.0`
src/_features.h: src/[^_]*.[hc]
- echo "#include <stddef.h>\nstatic const char *feature_flags[] __attribute__((__unused__)) = {" > $@
+ printf "#include <stddef.h>\nstatic const char *feature_flags[] __attribute__((__unused__)) = {\n" > $@
awk 'match ($$0, /netplan-feature:.*/ ) { $$0=substr($$0, RSTART, RLENGTH); print "\""$$2"\"," }' $^ >> $@
echo "NULL, };" >> $@