summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu.trudel-lapierre@canonical.com>2019-08-15 16:32:10 -0400
committerMathieu Trudel-Lapierre <mathieu.trudel-lapierre@canonical.com>2019-08-15 16:32:10 -0400
commitc13ef8d2e684270c6fbe0a2d9b777c67e4864b24 (patch)
tree2a4387a637087b0439eaa629174b1d5ed7b5ccf2 /Makefile
parent97f5a501628ca14b808843dd8f7ea3dc96491072 (diff)
Make more small fixes to Makefile to cleanup doubled-up slashes
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index d62f86e..4b563a9 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ SYSTEMD_UNIT_DIR=$(shell pkg-config --variable=systemdsystemunitdir systemd)
BASH_COMPLETIONS_DIR=$(shell pkg-config --variable=completionsdir bash-completion || echo "/etc/bash_completion.d")
GCOV ?= gcov
-ROOTPREFIX ?= /
+ROOTPREFIX ?=
PREFIX ?= /usr
ROOTLIBEXECDIR ?= $(ROOTPREFIX)/lib
LIBEXECDIR ?= $(PREFIX)/lib
@@ -105,13 +105,13 @@ install: default
install -D -m 644 src/netplan-wpa@.service $(DESTDIR)/$(SYSTEMD_UNIT_DIR)/netplan-wpa@.service
install -T -D -m 644 netplan.completions $(DESTDIR)/$(BASH_COMPLETIONS_DIR)/netplan
# dbus
- mkdir -p $(DESTDIR)$(PREFIX)/share/dbus-1/system.d $(DESTDIR)$(PREFIX)/share/dbus-1/system-services
+ mkdir -p $(DESTDIR)/$(DATADIR)/dbus-1/system.d $(DESTDIR)/$(DATADIR)/dbus-1/system-services
install -m 755 netplan-dbus $(DESTDIR)/$(ROOTLIBEXECDIR)/netplan/
- install -m 644 dbus/io.netplan.Netplan.conf $(DESTDIR)$(PREFIX)/share/dbus-1/system.d/
- install -m 644 dbus/io.netplan.Netplan.service $(DESTDIR)$(PREFIX)/share/dbus-1/system-services/
+ install -m 644 dbus/io.netplan.Netplan.conf $(DESTDIR)/$(DATADIR)/dbus-1/system.d/
+ install -m 644 dbus/io.netplan.Netplan.service $(DESTDIR)/$(DATADIR)/dbus-1/system-services/
%.service: %.service.in
- sed -e "s#@ROOTLIBEXECDIR@#$(ROOTLIBEXECDIR)/#" $< > $@
+ sed -e "s#@ROOTLIBEXECDIR@#$(ROOTLIBEXECDIR)#" $< > $@
%.html: %.md