summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Dunkel <harri@afaics.de>2018-05-10 18:53:53 +0200
committerHarald Dunkel <harri@afaics.de>2018-05-10 18:53:53 +0200
commit77d90dc60746f3bf675056ff871d7928a5cbb011 (patch)
tree0f50ff813384ed428d04be4b04b4b5541f26ae01
parent7986c2e59ca44283ae96b263fdf979720f2fb2d1 (diff)
New upstream version 1.4.4
-rw-r--r--Makefile.am1
-rw-r--r--Makefile.in2
-rw-r--r--NEWS10
-rw-r--r--auth-dialog/Makefile.in1
-rwxr-xr-xconfigure60
-rw-r--r--configure.ac34
-rw-r--r--po/de.po147
-rw-r--r--properties/Makefile.in1
-rw-r--r--properties/nm-strongswan-dialog.ui4
9 files changed, 201 insertions, 59 deletions
diff --git a/Makefile.am b/Makefile.am
index 2b022bf..9b8c676 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,6 @@ AUTOMAKE_OPTIONS = foreign
SUBDIRS = properties auth-dialog po
-nmvpnservicedir = $(prefix)/lib/NetworkManager/VPN
nmvpnservice_DATA = nm-strongswan-service.name
@INTLTOOL_DESKTOP_RULE@
diff --git a/Makefile.in b/Makefile.in
index 810a85c..4688d15 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -387,6 +387,7 @@ mkdir_p = @mkdir_p@
nm_libexecdir = @nm_libexecdir@
nm_plugindir = @nm_plugindir@
nm_plugindir_abs = @nm_plugindir_abs@
+nmvpnservicedir = @nmvpnservicedir@
oldincludedir = @oldincludedir@
pdfdir = @pdfdir@
prefix = @prefix@
@@ -403,7 +404,6 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = properties auth-dialog po
-nmvpnservicedir = $(prefix)/lib/NetworkManager/VPN
nmvpnservice_DATA = nm-strongswan-service.name
appdatadir = $(datadir)/appdata
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
diff --git a/NEWS b/NEWS
index 979bdea..67b2e19 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,9 @@
+NetworkManager-strongswan-1.4.4
+-------------------------------
+
+- Fixed paths when building without libnm-glib
+- Fixed proposal tooltips and updated German translation
+
NetworkManager-strongswan-1.4.3
-------------------------------
@@ -32,7 +38,7 @@ NetworkManager-strongswan-1.3.1
-------------------------------
- Add PSK support
-- Updated German translations
+- Updated German translation
NetworkManager-strongswan-1.3.0
-------------------------------
@@ -49,7 +55,7 @@ NetworkManager-strongswan-1.1.2
- Additionally look for libnm-glib[-vpn] pkgconfig packages during configure
- Tooltips are translatable
-- Update German translations
+- Update German translation
NetworkManager-strongswan-1.1.1
-------------------------------
diff --git a/auth-dialog/Makefile.in b/auth-dialog/Makefile.in
index dbfed5b..2dbb0d6 100644
--- a/auth-dialog/Makefile.in
+++ b/auth-dialog/Makefile.in
@@ -330,6 +330,7 @@ mkdir_p = @mkdir_p@
nm_libexecdir = @nm_libexecdir@
nm_plugindir = @nm_plugindir@
nm_plugindir_abs = @nm_plugindir_abs@
+nmvpnservicedir = @nmvpnservicedir@
oldincludedir = @oldincludedir@
pdfdir = @pdfdir@
prefix = @prefix@
diff --git a/configure b/configure
index 8199d6c..320ee00 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for NetworkManager-strongswan 1.4.3.
+# Generated by GNU Autoconf 2.69 for NetworkManager-strongswan 1.4.4.
#
# Report bugs to <martin@strongswan.org>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='NetworkManager-strongswan'
PACKAGE_TARNAME='NetworkManager-strongswan'
-PACKAGE_VERSION='1.4.3'
-PACKAGE_STRING='NetworkManager-strongswan 1.4.3'
+PACKAGE_VERSION='1.4.4'
+PACKAGE_STRING='NetworkManager-strongswan 1.4.4'
PACKAGE_BUGREPORT='martin@strongswan.org'
PACKAGE_URL=''
@@ -634,6 +634,7 @@ ac_includes_default="\
ac_subst_vars='am__EXEEXT_FALSE
am__EXEEXT_TRUE
LTLIBOBJS
+nmvpnservicedir
nm_plugindir_abs
nm_plugindir
nm_libexecdir
@@ -837,6 +838,8 @@ with_sysroot
enable_libtool_lock
enable_nls
with_charon
+with_nm_libexecdir
+with_nm_plugindir
enable_nm_absolute_paths
with_libnm_glib
enable_more_warnings
@@ -1416,7 +1419,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures NetworkManager-strongswan 1.4.3 to adapt to many kinds of systems.
+\`configure' configures NetworkManager-strongswan 1.4.4 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1488,7 +1491,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of NetworkManager-strongswan 1.4.3:";;
+ short | recursive ) echo "Configuration of NetworkManager-strongswan 1.4.4:";;
esac
cat <<\_ACEOF
@@ -1527,9 +1530,10 @@ Optional Packages:
--with-gnu-ld assume the C compiler uses GNU ld [default=no]
--with-sysroot[=DIR] Search for dependent libraries within DIR (or the
compiler's sysroot if not specified).
- --with-charon=file path to the strongSwan charon NetworkManager
- backend"
- --without-libnm-glib Build NetworkManager-strongswan without libnm-glib
+ --with-charon=file path to the strongSwan charon NetworkManager backend
+ --nm-libexecdir=path use custom path where the auth dialog is installed
+ --nm-plugindir=path use custom path where the NM plugin is installed
+ --without-libnm-glib build NetworkManager-strongswan without libnm-glib
comatibility
Some influential environment variables:
@@ -1635,7 +1639,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-NetworkManager-strongswan configure 1.4.3
+NetworkManager-strongswan configure 1.4.4
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2058,7 +2062,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by NetworkManager-strongswan $as_me 1.4.3, which was
+It was created by NetworkManager-strongswan $as_me 1.4.4, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2921,7 +2925,7 @@ fi
# Define the identity of the package.
PACKAGE='NetworkManager-strongswan'
- VERSION='1.4.3'
+ VERSION='1.4.4'
cat >>confdefs.h <<_ACEOF
@@ -14042,6 +14046,18 @@ else
fi
+
+# Check whether --with-nm-libexecdir was given.
+if test "${with_nm_libexecdir+set}" = set; then :
+ withval=$with_nm_libexecdir; nm_libexecdir="$withval"
+fi
+
+
+# Check whether --with-nm-plugindir was given.
+if test "${with_nm_plugindir+set}" = set; then :
+ withval=$with_nm_plugindir; nm_plugindir="$withval"
+fi
+
# Check whether --enable-nm-absolute-paths was given.
if test "${enable_nm_absolute_paths+set}" = set; then :
enableval=$enable_nm_absolute_paths;
@@ -14434,15 +14450,29 @@ else
$as_echo "yes" >&6; }
fi
+ if test -z "$nm_libexecdir"; then
+ nm_libexecdir=$($PKG_CONFIG --variable=libgnome_serverdir NetworkManager)
+ fi
+ if test -z "$nm_plugindir"; then
+ nm_plugindir=$($PKG_CONFIG --variable=plugindir NetworkManager)
+ fi
+else
+ if test -z "$nm_libexecdir"; then
+ nm_libexecdir=$($PKG_CONFIG --variable=exec_prefix libnm)/lib/NetworkManager
+ fi
+ if test -z "$nm_plugindir"; then
+ nm_plugindir=$($PKG_CONFIG --variable=libdir libnm)/NetworkManager
+ fi
fi
-nm_libexecdir=$($PKG_CONFIG --variable=libgnome_serverdir NetworkManager)
-nm_plugindir=$($PKG_CONFIG --variable=plugindir NetworkManager)
test x"$enable_nm_absolute_paths" = x"yes" && nm_plugindir_abs="$(nm_plugindir)/"
+nmvpnservicedir=$($PKG_CONFIG --variable=vpnservicedir libnm)
+
+
# Check whether --enable-more-warnings was given.
if test "${enable_more_warnings+set}" = set; then :
enableval=$enable_more_warnings; set_more_warnings="$enableval"
@@ -15041,7 +15071,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by NetworkManager-strongswan $as_me 1.4.3, which was
+This file was extended by NetworkManager-strongswan $as_me 1.4.4, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -15107,7 +15137,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-NetworkManager-strongswan config.status 1.4.3
+NetworkManager-strongswan config.status 1.4.4
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index fdeffa6..1d77493 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ(2.52)
-AC_INIT(NetworkManager-strongswan, 1.4.3, martin@strongswan.org, NetworkManager-strongswan)
+AC_INIT(NetworkManager-strongswan, 1.4.4, martin@strongswan.org, NetworkManager-strongswan)
AM_INIT_AUTOMAKE([subdir-objects])
AM_MAINTAINER_MODE
@@ -48,17 +48,27 @@ PKG_CHECK_MODULES(LIBSECRET, libsecret-1)
AC_ARG_WITH(
[charon],
- AS_HELP_STRING([--with-charon=file],[path to the strongSwan charon NetworkManager backend"]),
+ AS_HELP_STRING([--with-charon=file],[path to the strongSwan charon NetworkManager backend]),
[AC_SUBST(charon, "$withval")],
[AC_SUBST(charon, "${libexecdir}/ipsec/charon-nm")]
)
+AC_ARG_WITH(
+ [nm-libexecdir],
+ AS_HELP_STRING([--nm-libexecdir=path],[use custom path where the auth dialog is installed]),
+ [nm_libexecdir="$withval"], []
+)
+AC_ARG_WITH(
+ [nm-plugindir],
+ AS_HELP_STRING([--nm-plugindir=path],[use custom path where the NM plugin is installed]),
+ [nm_plugindir="$withval"], []
+)
AC_ARG_ENABLE(
[nm-absolute-paths],
AS_HELP_STRING([--enable-nm-absolute-paths],[use absolute paths for NM plugins in the .name file])
)
AC_ARG_WITH(
[libnm-glib],
- AS_HELP_STRING([--without-libnm-glib], [Build NetworkManager-strongswan without libnm-glib comatibility]),
+ AS_HELP_STRING([--without-libnm-glib], [build NetworkManager-strongswan without libnm-glib comatibility]),
[with_libnm_glib=no],
[with_libnm_glib=yes]
)
@@ -73,15 +83,29 @@ PKG_CHECK_MODULES(LIBNMA, libnma >= 1.1.0)
if test x"$with_libnm_glib" != xno; then
PKG_CHECK_MODULES(LIBNM_GLIB, NetworkManager >= 1.1.0 libnm-util libnm-glib libnm-glib-vpn)
PKG_CHECK_MODULES(LIBNM_GTK, libnm-gtk >= 1.1.0)
+ if test -z "$nm_libexecdir"; then
+ nm_libexecdir=$($PKG_CONFIG --variable=libgnome_serverdir NetworkManager)
+ fi
+ if test -z "$nm_plugindir"; then
+ nm_plugindir=$($PKG_CONFIG --variable=plugindir NetworkManager)
+ fi
+else
+ if test -z "$nm_libexecdir"; then
+ nm_libexecdir=$($PKG_CONFIG --variable=exec_prefix libnm)/lib/NetworkManager
+ fi
+ if test -z "$nm_plugindir"; then
+ nm_plugindir=$($PKG_CONFIG --variable=libdir libnm)/NetworkManager
+ fi
fi
-nm_libexecdir=$($PKG_CONFIG --variable=libgnome_serverdir NetworkManager)
AC_SUBST(nm_libexecdir)
-nm_plugindir=$($PKG_CONFIG --variable=plugindir NetworkManager)
AC_SUBST(nm_plugindir)
test x"$enable_nm_absolute_paths" = x"yes" && nm_plugindir_abs="$(nm_plugindir)/"
AC_SUBST(nm_plugindir_abs)
+nmvpnservicedir=$($PKG_CONFIG --variable=vpnservicedir libnm)
+AC_SUBST(nmvpnservicedir)
+
NM_COMPILER_WARNINGS
AC_CONFIG_FILES([
diff --git a/po/de.po b/po/de.po
index 8882b90..5ac8708 100644
--- a/po/de.po
+++ b/po/de.po
@@ -6,7 +6,7 @@ msgid ""
msgstr ""
"Project-Id-Version: NetworkManager-strongswan\n"
"Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2013-11-25 18:14+0100\n"
+"POT-Creation-Date: 2018-02-23 15:27+0100\n"
"PO-Revision-Date: 2010-02-18 09:20+0100\n"
"Last-Translator: Martin Willi <martin@strongswan.org>\n"
"Language-Team: de <martin@strongswan.org>\n"
@@ -15,31 +15,31 @@ msgstr ""
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-#: ../properties/nm-strongswan.c:37
+#: ../properties/nm-strongswan.c:43
msgid "IPsec/IKEv2 (strongswan)"
msgstr "IPsec/IKEv2 (strongswan)"
-#: ../properties/nm-strongswan.c:38
+#: ../properties/nm-strongswan.c:44
msgid "IPsec with the IKEv2 key exchange protocol."
msgstr "IPsec mit dem IKEv2 Protokoll."
-#: ../properties/nm-strongswan.c:208
+#: ../properties/nm-strongswan.c:318
msgid "Certificate/private key"
msgstr "Zertifikat/Privater Schlüssel"
-#: ../properties/nm-strongswan.c:209
+#: ../properties/nm-strongswan.c:319
msgid "Certificate/ssh-agent"
msgstr "Zertifikat/ssh-agent"
-#: ../properties/nm-strongswan.c:210
+#: ../properties/nm-strongswan.c:320
msgid "Smartcard"
msgstr "Smartcard"
-#: ../properties/nm-strongswan.c:211
+#: ../properties/nm-strongswan.c:321
msgid "EAP"
msgstr "EAP"
-#: ../properties/nm-strongswan.c:212
+#: ../properties/nm-strongswan.c:322
msgid "Pre-shared key"
msgstr "Pre-shared Key"
@@ -104,14 +104,30 @@ msgid "Client certificate to use for client authentication."
msgstr "Zertifikat des Clients für dessen Authentisierung."
#: ../properties/nm-strongswan-dialog.ui.h:14
+msgid "_Password:"
+msgstr "_Passwort:"
+
+#: ../properties/nm-strongswan-dialog.ui.h:15
+msgid ""
+"The password to use for authentication against the gateway (min. 20 "
+"characters for PSKs)."
+msgstr ""
+"Das Passwort für die Authentisierung gegenüber dem Gateway (min. 20 Zeichen "
+"für PSKs)."
+
+#: ../properties/nm-strongswan-dialog.ui.h:16
+msgid "_Show password"
+msgstr "Passwort _anzeigen"
+
+#: ../properties/nm-strongswan-dialog.ui.h:17
msgid "<b>Options</b>"
msgstr "<b>Optionen</b>"
-#: ../properties/nm-strongswan-dialog.ui.h:15
+#: ../properties/nm-strongswan-dialog.ui.h:18
msgid "Request an _inner IP address"
msgstr "_Innere IP-Adresse beziehen"
-#: ../properties/nm-strongswan-dialog.ui.h:16
+#: ../properties/nm-strongswan-dialog.ui.h:19
msgid ""
"The Gateway may provide addresses from a pool to use for communication in "
"the Gateways network. Check to request such an address."
@@ -120,11 +136,11 @@ msgstr ""
"Kommunikation im dahinterliegenden Netz verwenden kann. Aktivieren, um eine "
"solche Adresse zu beziehen."
-#: ../properties/nm-strongswan-dialog.ui.h:17
+#: ../properties/nm-strongswan-dialog.ui.h:20
msgid "En_force UDP encapsulation"
msgstr "Erzwingen einer zusätzlichen Einbettung der Datenpakete in _UDP"
-#: ../properties/nm-strongswan-dialog.ui.h:18
+#: ../properties/nm-strongswan-dialog.ui.h:21
msgid ""
"Some firewalls block ESP traffic. Enforcing UDP capsulation even if no NAT "
"situation is detected might help in such cases."
@@ -133,11 +149,11 @@ msgstr ""
"erzwingen einer zustzlichen Einbettung in UDP, auch wenn kein NAT-Router "
"detektiert wurde, kann in solchen Situationen hilfreich sein."
-#: ../properties/nm-strongswan-dialog.ui.h:19
+#: ../properties/nm-strongswan-dialog.ui.h:22
msgid "Use IP c_ompression"
msgstr "IP-Pakete k_omprimieren"
-#: ../properties/nm-strongswan-dialog.ui.h:20
+#: ../properties/nm-strongswan-dialog.ui.h:23
msgid ""
"IPComp compresses raw IP packets before they get encrypted. This saves some "
"bandwidth, but uses more processing power."
@@ -145,36 +161,101 @@ msgstr ""
"IPComp komprimiert IP-Pakete, bevor sie verschlüsselt werden. Diese Option "
"kann Bandbreite sparen, benötigt jedoch zusätzliche Rechenleistung."
-#: ../auth-dialog/main.c:170 ../auth-dialog/main.c:177
-#: ../auth-dialog/main.c:184 ../auth-dialog/main.c:191
-msgid "VPN password required"
-msgstr "VPN Passwort notwendig"
+#: ../properties/nm-strongswan-dialog.ui.h:24
+msgid "<b>Cipher proposals</b>"
+msgstr "<b>Algorithmen</b>"
+
+#: ../properties/nm-strongswan-dialog.ui.h:25
+msgid "_Enable custom proposals"
+msgstr "_Eigene Algorithmen verwenden"
+
+#: ../properties/nm-strongswan-dialog.ui.h:26
+msgid "_IKE:"
+msgstr "_IKE:"
-#: ../auth-dialog/main.c:171
-msgid "EAP password required to establish VPN connection:"
-msgstr "Für die Erstellung des VPN-Tunnels ist ein EAP-Passwort erforderlich:"
+#: ../properties/nm-strongswan-dialog.ui.h:27
+msgid "A list of proposals for IKE separated by \";\""
+msgstr "Eine Liste von Proposals für IKE getrennt mit \";\""
-#: ../auth-dialog/main.c:178
-msgid "Private key decryption password required to establish VPN connection:"
+#: ../properties/nm-strongswan-dialog.ui.h:28
+msgid "_ESP:"
+msgstr "_ESP:"
+
+#: ../properties/nm-strongswan-dialog.ui.h:29
+msgid "A list of proposals for ESP separated by \";\""
+msgstr "Eine Liste von Proposals für ESP getrennt mit \";\""
+
+#: ../auth-dialog/main.c:137
+#, c-format
+msgid "EAP password required to establish VPN connection '%s'."
msgstr ""
-"Der Private Schlüssel für die Erstellung des VPN-Tunnels ist durch ein "
-"Passwort geschützt:"
+"Für die Erstellung des VPN-Tunnels '%s' ist ein EAP-Passwort erforderlich."
-#: ../auth-dialog/main.c:185
+#: ../auth-dialog/main.c:142
+#, c-format
msgid ""
-"Pre-shared key required to establish VPN connection (min. 20 characters):"
+"Private key decryption password required to establish VPN connection '%s'."
msgstr ""
-"Für die Erstellung des VPN-Tunnels ist ein Pre-shared Key erforderlich (min. "
-"20 Zeichen):"
+"Der Private Schlüssel für die Erstellung des VPN-Tunnels '%s' ist durch ein "
+"Passwort geschützt."
-#: ../auth-dialog/main.c:192
-msgid "Smartcard PIN required to establish VPN connection:"
-msgstr "Für die Smartcard ist eine PIN erforderlich:"
+#: ../auth-dialog/main.c:147
+#, c-format
+msgid ""
+"Pre-shared key required to establish VPN connection '%s' (min. 20 "
+"characters)."
+msgstr ""
+"Für die Erstellung des VPN-Tunnels '%s' ist ein Pre-shared Key erforderlich "
+"(min. 20 Zeichen)."
-#: ../auth-dialog/main.c:242
+#: ../auth-dialog/main.c:153
+#, c-format
+msgid "Smartcard PIN required to establish VPN connection '%s'."
+msgstr ""
+"Die Smartcard für die Erstellung des VPN-Tunnels '%s' ist durch eine PIN "
+"geschützt."
+
+#: ../auth-dialog/main.c:164 ../auth-dialog/main.c:182
+#: ../auth-dialog/main.c:332
+msgid "Authenticate VPN"
+msgstr "VPN Authentisierung"
+
+#: ../auth-dialog/main.c:166
+msgid "Password:"
+msgstr "Passwort:"
+
+#: ../auth-dialog/main.c:350
msgid ""
"Configuration uses ssh-agent for authentication, but ssh-agent is not "
"running!"
msgstr ""
"Die Konfiguration verwendet ssh-agent für die Authentisierung, aber ssh-"
"agent ist nicht gestartet!"
+
+#: ../NetworkManager-strongswan.appdata.xml.in.h:1
+msgid "strongSwan VPN client"
+msgstr "strongSwan VPN Client"
+
+#: ../NetworkManager-strongswan.appdata.xml.in.h:2
+msgid "strongSwan based client for IPsec virtual private networks"
+msgstr "Auf strongSwan basierender Client für IPsec VPNs"
+
+#: ../NetworkManager-strongswan.appdata.xml.in.h:3
+msgid ""
+"Support for configuring IPsec based virtual private network connections."
+msgstr ""
+"Unterstützung für die Konfiguration von IPsec-basierten VPN Verbindungen."
+
+#: ../NetworkManager-strongswan.appdata.xml.in.h:4
+msgid ""
+"Compatible with IKEv2 key exchange and multiple authentication mechanisms."
+msgstr ""
+"Kompatibel mit dem IKEv2 Schlüsselaustausch-Protokoll und verschiedenen "
+"Authentisierungsmethoden."
+
+#: ../NetworkManager-strongswan.appdata.xml.in.h:5
+msgid "strongSwan Developers"
+msgstr "strongSwan Entwickler"
+
+#~ msgid "VPN password required"
+#~ msgstr "VPN Passwort notwendig"
diff --git a/properties/Makefile.in b/properties/Makefile.in
index 6f5c115..bc01ef7 100644
--- a/properties/Makefile.in
+++ b/properties/Makefile.in
@@ -376,6 +376,7 @@ mkdir_p = @mkdir_p@
nm_libexecdir = @nm_libexecdir@
nm_plugindir = @nm_plugindir@
nm_plugindir_abs = @nm_plugindir_abs@
+nmvpnservicedir = @nmvpnservicedir@
oldincludedir = @oldincludedir@
pdfdir = @pdfdir@
prefix = @prefix@
diff --git a/properties/nm-strongswan-dialog.ui b/properties/nm-strongswan-dialog.ui
index ba00c5c..4333235 100644
--- a/properties/nm-strongswan-dialog.ui
+++ b/properties/nm-strongswan-dialog.ui
@@ -497,7 +497,7 @@
<property name="visible">True</property>
<property name="can_focus">True</property>
<property name="has_tooltip">True</property>
- <property name="tooltip_text" translatable="yes">A list of proposals for IKE separated by ";". (A suffix of ! enforces strict mode)</property>
+ <property name="tooltip_text" translatable="yes">A list of proposals for IKE separated by ";"</property>
<property name="invisible_char">•</property>
<property name="invisible_char_set">True</property>
<property name="primary_icon_activatable">False</property>
@@ -532,7 +532,7 @@
<property name="visible">True</property>
<property name="can_focus">True</property>
<property name="has_tooltip">True</property>
- <property name="tooltip_text" translatable="yes">A list of proposals for ESP separated by ";". (A suffix of ! enforces strict mode)</property>
+ <property name="tooltip_text" translatable="yes">A list of proposals for ESP separated by ";"</property>
<property name="invisible_char">•</property>
<property name="invisible_char_set">True</property>
<property name="primary_icon_activatable">False</property>