summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Dunkel <harri@afaics.de>2017-06-25 12:26:01 +0200
committerHarald Dunkel <harri@afaics.de>2017-06-25 12:26:01 +0200
commitc003374a6a862dbec071e01e28bf0acc7213ac8e (patch)
tree0667fb7c2f75845a64b98737b007e03259675fc4
parentc987238ceb4e7bdc8216e7e3867a349f173dfd82 (diff)
parent989153017b187228ca12916cc73cfc707bc0f83c (diff)
Updated version 1.4.2 from 'upstream/1.4.2'
with Debian dir 8e9eba3f7e30a655dffe14d8e2b26ddd4194f3fa
-rw-r--r--Makefile.in3
-rw-r--r--NEWS6
-rw-r--r--auth-dialog/Makefile.in4
-rwxr-xr-xconfigure20
-rw-r--r--configure.ac2
-rw-r--r--properties/Makefile.in4
-rw-r--r--properties/nm-strongswan-dialog.ui145
-rw-r--r--properties/nm-strongswan.c59
8 files changed, 226 insertions, 17 deletions
diff --git a/Makefile.in b/Makefile.in
index c1074c6..0714c99 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -193,8 +193,7 @@ CTAGS = ctags
CSCOPE = cscope
DIST_SUBDIRS = $(SUBDIRS)
am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in NEWS \
- compile config.guess config.sub depcomp install-sh ltmain.sh \
- missing
+ compile config.guess config.sub install-sh ltmain.sh missing
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
diff --git a/NEWS b/NEWS
index 371e62b..2ccfe3a 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,9 @@
+NetworkManager-strongswan-1.4.2
+-------------------------------
+
+- Add support to configure IKE/ESP proposals
+- Explicitly prevent PIN from getting stored
+
NetworkManager-strongswan-1.4.1
-------------------------------
diff --git a/auth-dialog/Makefile.in b/auth-dialog/Makefile.in
index d152d7b..dbfed5b 100644
--- a/auth-dialog/Makefile.in
+++ b/auth-dialog/Makefile.in
@@ -376,9 +376,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__confi
exit 1;; \
esac; \
done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign auth-dialog/Makefile'; \
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu auth-dialog/Makefile'; \
$(am__cd) $(top_srcdir) && \
- $(AUTOMAKE) --foreign auth-dialog/Makefile
+ $(AUTOMAKE) --gnu auth-dialog/Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
*config.status*) \
diff --git a/configure b/configure
index 6a2b29e..0be9d7e 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for NetworkManager-strongswan 1.4.1.
+# Generated by GNU Autoconf 2.69 for NetworkManager-strongswan 1.4.2.
#
# Report bugs to <martin@strongswan.org>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='NetworkManager-strongswan'
PACKAGE_TARNAME='NetworkManager-strongswan'
-PACKAGE_VERSION='1.4.1'
-PACKAGE_STRING='NetworkManager-strongswan 1.4.1'
+PACKAGE_VERSION='1.4.2'
+PACKAGE_STRING='NetworkManager-strongswan 1.4.2'
PACKAGE_BUGREPORT='martin@strongswan.org'
PACKAGE_URL=''
@@ -1413,7 +1413,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures NetworkManager-strongswan 1.4.1 to adapt to many kinds of systems.
+\`configure' configures NetworkManager-strongswan 1.4.2 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1485,7 +1485,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of NetworkManager-strongswan 1.4.1:";;
+ short | recursive ) echo "Configuration of NetworkManager-strongswan 1.4.2:";;
esac
cat <<\_ACEOF
@@ -1630,7 +1630,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-NetworkManager-strongswan configure 1.4.1
+NetworkManager-strongswan configure 1.4.2
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2053,7 +2053,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by NetworkManager-strongswan $as_me 1.4.1, which was
+It was created by NetworkManager-strongswan $as_me 1.4.2, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2916,7 +2916,7 @@ fi
# Define the identity of the package.
PACKAGE='NetworkManager-strongswan'
- VERSION='1.4.1'
+ VERSION='1.4.2'
cat >>confdefs.h <<_ACEOF
@@ -15012,7 +15012,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by NetworkManager-strongswan $as_me 1.4.1, which was
+This file was extended by NetworkManager-strongswan $as_me 1.4.2, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -15078,7 +15078,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-NetworkManager-strongswan config.status 1.4.1
+NetworkManager-strongswan config.status 1.4.2
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index be348b3..52ff0a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ(2.52)
-AC_INIT(NetworkManager-strongswan, 1.4.1, martin@strongswan.org, NetworkManager-strongswan)
+AC_INIT(NetworkManager-strongswan, 1.4.2, martin@strongswan.org, NetworkManager-strongswan)
AM_INIT_AUTOMAKE([subdir-objects])
AM_MAINTAINER_MODE
diff --git a/properties/Makefile.in b/properties/Makefile.in
index 7494c6b..29fac63 100644
--- a/properties/Makefile.in
+++ b/properties/Makefile.in
@@ -445,9 +445,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__confi
exit 1;; \
esac; \
done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign properties/Makefile'; \
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu properties/Makefile'; \
$(am__cd) $(top_srcdir) && \
- $(AUTOMAKE) --foreign properties/Makefile
+ $(AUTOMAKE) --gnu properties/Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
*config.status*) \
diff --git a/properties/nm-strongswan-dialog.ui b/properties/nm-strongswan-dialog.ui
index 278fd00..ba00c5c 100644
--- a/properties/nm-strongswan-dialog.ui
+++ b/properties/nm-strongswan-dialog.ui
@@ -426,5 +426,150 @@
<property name="position">2</property>
</packing>
</child>
+ <child>
+ <object class="GtkVBox" id="proposals-vbox">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="spacing">6</property>
+ <child>
+ <object class="GtkLabel" id="proposals-label">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="xalign">0</property>
+ <property name="label" translatable="yes">&lt;b&gt;Cipher proposals&lt;/b&gt;</property>
+ <property name="use_markup">True</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkAlignment" id="proposal-alignment">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="left_padding">12</property>
+ <child>
+ <object class="GtkVBox" id="vbox1">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <child>
+ <object class="GtkCheckButton" id="proposal-check">
+ <property name="label" translatable="yes">_Enable custom proposals</property>
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">False</property>
+ <property name="use_underline">True</property>
+ <property name="draw_indicator">True</property>
+ </object>
+ <packing>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkTable" id="proposal-table">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="n_rows">2</property>
+ <property name="n_columns">2</property>
+ <property name="column_spacing">6</property>
+ <property name="row_spacing">6</property>
+ <child>
+ <object class="GtkLabel" id="ike-label">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="xalign">0</property>
+ <property name="ypad">1</property>
+ <property name="label" translatable="yes">_IKE:</property>
+ <property name="use_underline">True</property>
+ <property name="mnemonic_widget">ike-entry</property>
+ </object>
+ <packing>
+ <property name="x_options">GTK_FILL</property>
+ <property name="y_options"/>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkEntry" id="ike-entry">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="has_tooltip">True</property>
+ <property name="tooltip_text" translatable="yes">A list of proposals for IKE separated by ";". (A suffix of ! enforces strict mode)</property>
+ <property name="invisible_char">•</property>
+ <property name="invisible_char_set">True</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+ <property name="primary_icon_sensitive">True</property>
+ <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+ <property name="right_attach">2</property>
+ <property name="y_options"/>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkLabel" id="esp-label">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="xalign">0</property>
+ <property name="label" translatable="yes">_ESP:</property>
+ <property name="use_underline">True</property>
+ <property name="mnemonic_widget">address-entry</property>
+ </object>
+ <packing>
+ <property name="top_attach">1</property>
+ <property name="bottom_attach">2</property>
+ <property name="x_options">GTK_FILL</property>
+ <property name="y_options"/>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkEntry" id="esp-entry">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="has_tooltip">True</property>
+ <property name="tooltip_text" translatable="yes">A list of proposals for ESP separated by ";". (A suffix of ! enforces strict mode)</property>
+ <property name="invisible_char">•</property>
+ <property name="invisible_char_set">True</property>
+ <property name="primary_icon_activatable">False</property>
+ <property name="secondary_icon_activatable">False</property>
+ <property name="primary_icon_sensitive">True</property>
+ <property name="secondary_icon_sensitive">True</property>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+ <property name="right_attach">2</property>
+ <property name="top_attach">1</property>
+ <property name="bottom_attach">2</property>
+ <property name="y_options"/>
+ </packing>
+ </child>
+ </object>
+ <packing>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ </object>
+ </child>
+ </object>
+ <packing>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ <property name="position">3</property>
+ </packing>
+ </child>
</object>
</interface>
diff --git a/properties/nm-strongswan.c b/properties/nm-strongswan.c
index b791068..e893c1d 100644
--- a/properties/nm-strongswan.c
+++ b/properties/nm-strongswan.c
@@ -229,6 +229,15 @@ show_toggled_cb (GtkCheckButton *button, StrongswanPluginUiWidget *self)
}
static void
+toggle_proposal_cb(GtkCheckButton *button, StrongswanPluginUiWidget *self)
+{
+ StrongswanPluginUiWidgetPrivate *priv = STRONGSWAN_PLUGIN_UI_WIDGET_GET_PRIVATE (self);
+ gboolean visible = gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON(button));
+ gtk_widget_set_sensitive(GTK_WIDGET(gtk_builder_get_object(priv->builder, "ike-entry")), visible);
+ gtk_widget_set_sensitive(GTK_WIDGET(gtk_builder_get_object(priv->builder, "esp-entry")), visible);
+}
+
+static void
password_storage_changed_cb (GObject *entry, GParamSpec *pspec, gpointer user_data)
{
settings_changed_cb (NULL, STRONGSWAN_PLUGIN_UI_WIDGET (user_data));
@@ -372,6 +381,34 @@ init_plugin_ui (StrongswanPluginUiWidget *self, NMConnection *connection, GError
}
g_signal_connect (G_OBJECT (widget), "toggled", G_CALLBACK (settings_changed_cb), self);
+ widget = GTK_WIDGET (gtk_builder_get_object (priv->builder, "proposal-check"));
+ value = nm_setting_vpn_get_data_item(settings, "proposal");
+ if (value && strcmp(value, "yes") == 0)
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(widget), TRUE);
+ else
+ toggle_proposal_cb(GTK_CHECK_BUTTON(widget), self);
+ g_signal_connect (G_OBJECT (widget), "toggled", G_CALLBACK (toggle_proposal_cb), self);
+
+ widget = GTK_WIDGET(gtk_builder_get_object(priv->builder, "ike-entry"));
+ value = nm_setting_vpn_get_data_item(settings, "ike");
+ if (value)
+ {
+ value = g_strdelimit (g_strdup (value), ";", ',');
+ gtk_entry_set_text (GTK_ENTRY (widget), value);
+ g_free ((char*)value);
+ }
+ g_signal_connect (G_OBJECT (widget), "changed", G_CALLBACK (settings_changed_cb), self);
+
+ widget = GTK_WIDGET(gtk_builder_get_object(priv->builder, "esp-entry"));
+ value = nm_setting_vpn_get_data_item(settings, "esp");
+ if (value)
+ {
+ value = g_strdelimit (g_strdup (value), ";", ',');
+ gtk_entry_set_text (GTK_ENTRY (widget), value);
+ g_free ((char*)value);
+ }
+ g_signal_connect (G_OBJECT (widget), "changed", G_CALLBACK (settings_changed_cb), self);
+
return TRUE;
}
@@ -472,6 +509,8 @@ update_connection (NMVpnEditor *iface,
str = "agent";
break;
case 2:
+ nm_setting_set_secret_flags (NM_SETTING (settings), "password",
+ NM_SETTING_SECRET_FLAG_NOT_SAVED, NULL);
str = "smartcard";
break;
case 3:
@@ -507,6 +546,26 @@ update_connection (NMVpnEditor *iface,
active = gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON(widget));
nm_setting_vpn_add_data_item (settings, "ipcomp", active ? "yes" : "no");
+ widget = GTK_WIDGET (gtk_builder_get_object (priv->builder, "proposal-check"));
+ active = gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON(widget));
+ nm_setting_vpn_add_data_item (settings, "proposal", active ? "yes" : "no");
+
+ widget = GTK_WIDGET (gtk_builder_get_object (priv->builder, "ike-entry"));
+ str = (char *) gtk_entry_get_text (GTK_ENTRY (widget));
+ if (str && strlen (str)) {
+ str = g_strdelimit (g_strdup (str), ",", ';');
+ nm_setting_vpn_add_data_item (settings, "ike", str);
+ g_free (str);
+ }
+
+ widget = GTK_WIDGET (gtk_builder_get_object (priv->builder, "esp-entry"));
+ str = (char *) gtk_entry_get_text (GTK_ENTRY (widget));
+ if (str && strlen (str)) {
+ str = g_strdelimit (g_strdup (str), ",", ';');
+ nm_setting_vpn_add_data_item (settings, "esp", str);
+ g_free (str);
+ }
+
nm_connection_add_setting (connection, NM_SETTING (settings));
return TRUE;
}