summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorHarald Dunkel <harri@afaics.de>2018-02-21 10:06:08 +0100
committerHarald Dunkel <harri@afaics.de>2018-02-21 10:06:08 +0100
commit7986c2e59ca44283ae96b263fdf979720f2fb2d1 (patch)
treebf0daa74cda984e2ea1f8a7318c40c718f42944a /Makefile.in
parent989153017b187228ca12916cc73cfc707bc0f83c (diff)
New upstream version 1.4.3
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in26
1 files changed, 14 insertions, 12 deletions
diff --git a/Makefile.in b/Makefile.in
index 0714c99..810a85c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -856,6 +856,8 @@ distclean-generic:
maintainer-clean-generic:
@echo "This command is intended for maintainers to use"
@echo "it deletes files that may require special tools to rebuild."
+@WITH_LIBNM_GLIB_FALSE@install-data-hook:
+@WITH_LIBNM_GLIB_FALSE@uninstall-hook:
clean: clean-recursive
clean-am: clean-generic clean-libtool mostlyclean-am
@@ -958,18 +960,18 @@ uninstall-am: uninstall-appdataDATA uninstall-nmvpnserviceDATA
# Install a file with full path to plugins for an old gnome-shell
# https://bugzilla.gnome.org/show_bug.cgi?id=693590
-install-data-hook:
- mkdir -p $(DESTDIR)$(sysconfdir)/NetworkManager/VPN
- sed -e "1s|^|# This file is obsoleted by a file in $(nmvpnservicedir)\n\n|" \
- -e 's|[@]NM_LIBEXECDIR[@]|$(nm_libexecdir)|g' \
- -e 's|[@]NM_PLUGINDIR[@]|$(nm_plugindir)|g' \
- -e 's|[@]NM_PLUGINDIR_ABS[@]|$(nm_plugindir)|g' \
- -e 's|[@]CHARON[@]|$(charon)|' \
- <$(srcdir)/nm-strongswan-service.name.in \
- >$(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-strongswan-service.name
-
-uninstall-hook:
- rm -f $(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-strongswan-service.name
+@WITH_LIBNM_GLIB_TRUE@install-data-hook:
+@WITH_LIBNM_GLIB_TRUE@ mkdir -p $(DESTDIR)$(sysconfdir)/NetworkManager/VPN
+@WITH_LIBNM_GLIB_TRUE@ sed -e "1s|^|# This file is obsoleted by a file in $(nmvpnservicedir)\n\n|" \
+@WITH_LIBNM_GLIB_TRUE@ -e 's|[@]NM_LIBEXECDIR[@]|$(nm_libexecdir)|g' \
+@WITH_LIBNM_GLIB_TRUE@ -e 's|[@]NM_PLUGINDIR[@]|$(nm_plugindir)|g' \
+@WITH_LIBNM_GLIB_TRUE@ -e 's|[@]NM_PLUGINDIR_ABS[@]|$(nm_plugindir)|g' \
+@WITH_LIBNM_GLIB_TRUE@ -e 's|[@]CHARON[@]|$(charon)|' \
+@WITH_LIBNM_GLIB_TRUE@ <$(srcdir)/nm-strongswan-service.name.in \
+@WITH_LIBNM_GLIB_TRUE@ >$(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-strongswan-service.name
+
+@WITH_LIBNM_GLIB_TRUE@uninstall-hook:
+@WITH_LIBNM_GLIB_TRUE@ rm -f $(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-strongswan-service.name
nm-strongswan-service.name: $(srcdir)/nm-strongswan-service.name.in
$(AM_V_GEN) \