summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNilesh Patra <nilesh@debian.org>2021-10-25 02:30:44 +0530
committerNilesh Patra <nilesh@debian.org>2021-10-25 02:30:44 +0530
commit5f0f557330a7fa5a0dbacac966bde66fc763842e (patch)
tree8cb420f2e706a7e8dbbb4b2973b901fb305c8f92
parentce7a1b0f9440269432eee5b2ffd2094c6e32ad75 (diff)
Switch to pytest instead of nose
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules20
2 files changed, 1 insertions, 21 deletions
diff --git a/debian/control b/debian/control
index aaa6e8e..63e3944 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,6 @@ Build-Depends: debhelper-compat (= 13),
python3-matplotlib,
python3-tk,
python3-sphinx,
- python3-nose,
python3-networkx,
python3-nibabel,
python3-setuptools,
@@ -34,7 +33,6 @@ Depends: ${python3:Depends},
python3-numpy,
python3-scipy
Recommends: python3-matplotlib,
- python3-nose,
python3-nibabel,
python3-networkx
Description: timeseries analysis for neuroscience data (nitime)
diff --git a/debian/rules b/debian/rules
index 40d659b..c6aa873 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,16 +15,10 @@ export HOME=$(CURDIR)/build
%:
dh $@ --with python3 --buildsystem pybuild
-override_dh_auto_test:
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- : # Do not test just after build, lets install and then test
-endif
-
override_dh_auto_install:
dh_auto_install
mkdir -p $(MPLCONFIGDIR) # just in case
- echo "backend : Agg" >| $(MPLCONFIGDIR)/matplotlibrc
: # Prune duplicate LICENSE file
find debian/ -name LICENSE -delete
: # Only now lets build docs
@@ -38,19 +32,7 @@ ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
: # objects inventory is of no use for the package
-rm doc/_build/html/objects.inv
for f in `find . -name "*.html"`; do \
- sed -i '/cloudflare/d' $$f; \
- done
-endif
-
-# All tests later on
-# cd build to prevent use of local/not-built source tree
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- cd build; \
- for PYTHON in $(shell py3versions -r); do \
- echo "I: Running NiTime unittests using $$PYTHON"; \
- PYTHONPATH=$$(/bin/ls -d $(INSTALL_PATH)/usr/lib/$$PYTHON/*-packages) \
- MPLCONFIGDIR=/tmp/ \
- $$PYTHON /usr/bin/nosetests3 '--exclude=test_(coherence_linear_dependence|lazy_reload)' nitime; \
+ sed -i -e '/cloudflare/d' -e '/jsdelivr/d' $$f; \
done
endif