summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael R. Crusoe <michael.crusoe@gmail.com>2023-12-14 22:51:37 +0100
committerÉtienne Mollier <emollier@debian.org>2023-12-14 22:51:37 +0100
commit8a411508b795f7bd8a71bb3806df745ea9368659 (patch)
tree93692fc930f97051a472c05f5eadd130f875ec12
parent4ac0d7cf1c2b1b90a3cac44a45262952b76ce291 (diff)
Python3 fixes
Last-Update: 2019-12-15 15:37:17 Bug-Debian: https://bugs.debian.org/937145 Gbp-Pq: Name python3
-rw-r--r--doc/Makefile2
-rwxr-xr-xsetup.py2
-rwxr-xr-xtools/build_modref_templates.py2
-rwxr-xr-xtools/build_release2
-rwxr-xr-xtools/ex2rst2
-rwxr-xr-xtools/github_stats.py4
-rwxr-xr-xtools/gitwash_dumper.py4
-rwxr-xr-xtools/make_examples.py2
-rwxr-xr-xtools/release2
9 files changed, 11 insertions, 11 deletions
diff --git a/doc/Makefile b/doc/Makefile
index c2a1c6c..6396445 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -37,7 +37,7 @@ htmlonly:
@echo "Build finished. The HTML pages are in _build/html."
api:
- python ../tools/build_modref_templates.py
+ python3 ../tools/build_modref_templates.py
@echo "Build API docs finished."
html: rstexamples api htmlonly
diff --git a/setup.py b/setup.py
index 3974b51..abb8a18 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Setup file for the Python nitime package.
This file only contains cython components.
diff --git a/tools/build_modref_templates.py b/tools/build_modref_templates.py
index 43ca948..284fd21 100755
--- a/tools/build_modref_templates.py
+++ b/tools/build_modref_templates.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Script to auto-generate our API docs.
"""
# stdlib imports
diff --git a/tools/build_release b/tools/build_release
index 00c16ab..2bfd958 100755
--- a/tools/build_release
+++ b/tools/build_release
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Nitime release build script.
"""
from toollib import *
diff --git a/tools/ex2rst b/tools/ex2rst
index 9a7c5ed..8d55dab 100755
--- a/tools/ex2rst
+++ b/tools/ex2rst
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
#
# Note: this file is copied (possibly with minor modifications) from the
# sources of the PyMVPA project - http://pymvpa.org. It remains licensed as
diff --git a/tools/github_stats.py b/tools/github_stats.py
index 2f4fb36..543971a 100755
--- a/tools/github_stats.py
+++ b/tools/github_stats.py
@@ -1,11 +1,11 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Simple tools to query github.com and gather stats about issues.
"""
#-----------------------------------------------------------------------------
# Imports
#-----------------------------------------------------------------------------
-from __future__ import print_function
+
import json
import re
diff --git a/tools/gitwash_dumper.py b/tools/gitwash_dumper.py
index 000245a..b002f65 100755
--- a/tools/gitwash_dumper.py
+++ b/tools/gitwash_dumper.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
''' Checkout gitwash repo into directory and do search replace on name '''
import os
@@ -84,7 +84,7 @@ def copy_replace(replace_pairs,
for rep_glob in rep_globs:
fnames += fnmatch.filter(out_fnames, rep_glob)
if verbose:
- print '\n'.join(fnames)
+ print('\n'.join(fnames))
for fname in fnames:
filename_search_replace(replace_pairs, fname, False)
for in_exp, out_exp in renames:
diff --git a/tools/make_examples.py b/tools/make_examples.py
index ba5452a..0f1ae05 100755
--- a/tools/make_examples.py
+++ b/tools/make_examples.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Run the py->rst conversion and run all examples.
This also creates the index.rst file appropriately, makes figures, etc.
diff --git a/tools/release b/tools/release
index 26761a5..6d9d382 100755
--- a/tools/release
+++ b/tools/release
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Nitime release script.
This should only be run at real release time.