summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJo Shields <directhex@apebox.org>2013-10-30 17:09:36 +0000
committerJo Shields <directhex@apebox.org>2013-10-30 17:09:36 +0000
commitc8a31d3ca78633402985576d5250ce8d57d4ea17 (patch)
tree7c1af991c537a10113cc0cb3c74d6f6939424ac0 /debian
parent86c879a93dc7f9ffeff6a048bc6af6afe18449d3 (diff)
Use DBus# 2.0 API.
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/use_dbussharp_2.pc15
-rwxr-xr-xdebian/rules2
4 files changed, 20 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 6c65ea2..eef7314 100644
--- a/debian/control
+++ b/debian/control
@@ -5,13 +5,13 @@ Maintainer: Debian CLI Libraries Team <pkg-cli-libs-team@lists.alioth.debian.org
Uploaders: Sebastian Dröge <slomo@debian.org>,
Mirco Bauer <meebey@debian.org>,
Chow Loong Jin <hyperair@debian.org>
-Build-Depends: debhelper (>= 7.2)
+Build-Depends: debhelper (>= 7.2), dh-autoreconf
Build-Depends-Indep: cli-common-dev (>= 0.5.4),
mono-devel (>= 2.4.3),
monodoc-base (>= 1.1.18),
pkg-config,
- libdbus1.0-cil-dev (>= 0.7),
- libdbus-glib1.0-cil-dev (>= 0.5),
+ libdbus2.0-cil-dev (>= 0.7),
+ libdbus-glib2.0-cil-dev (>= 0.5),
libgtk2.0-cil-dev (>= 2.8)
Standards-Version: 3.9.2
Homepage: http://www.ndesk.org/NotifySharp
diff --git a/debian/patches/series b/debian/patches/series
index 0182781..485344f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@
03-use-dbus-sharp.patch
04-fix-app-name-derivation.patch
05-fix-crash-when-notification-updates-fail.patch
+use_dbussharp_2.pc
diff --git a/debian/patches/use_dbussharp_2.pc b/debian/patches/use_dbussharp_2.pc
new file mode 100644
index 0000000..504d8c2
--- /dev/null
+++ b/debian/patches/use_dbussharp_2.pc
@@ -0,0 +1,15 @@
+Index: notify-sharp/configure.ac
+===================================================================
+--- notify-sharp.orig/configure.ac 2013-10-30 17:08:11.823924561 +0000
++++ notify-sharp/configure.ac 2013-10-30 17:08:39.132039728 +0000
+@@ -68,8 +68,8 @@
+
+ DBUS_SHARP_REQ_VERSION=0.7
+ DBUS_SHARP_GLIB_REQ_VERSION=0.5
+-PKG_CHECK_MODULES(DBUS_SHARP, dbus-sharp-1.0 >= $DBUS_SHARP_REQ_VERSION \
+- dbus-sharp-glib-1.0 >= $DBUS_SHARP_GLIB_REQ_VERSION)
++PKG_CHECK_MODULES(DBUS_SHARP, dbus-sharp-2.0 >= $DBUS_SHARP_REQ_VERSION \
++ dbus-sharp-glib-2.0 >= $DBUS_SHARP_GLIB_REQ_VERSION)
+ AC_SUBST(DBUS_SHARP_LIBS)
+
+ required_assemblies="Mono.Posix"
diff --git a/debian/rules b/debian/rules
index 876ed19..0dfcd99 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,4 +13,4 @@ override_dh_makeclilibs:
dh_makeclilibs -m0.4.0~r2998
%:
- dh $@ --with=cli
+ dh $@ --with cli,autoreconf