summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <dimitri.ledkov@canonical.com>2013-12-26 20:07:37 +0000
committerDimitri John Ledkov <dimitri.ledkov@canonical.com>2013-12-26 20:07:37 +0000
commit451b0f6cc698ef3f8a17d866d2a3f13ba1dbcef6 (patch)
treeabd699e266c941127486e4a8942155959ed61e74
parentbe5a5ed141976a47ea174df5013803174659878c (diff)
* Fix FTBFS - "error: invalid use of undefined type 'structHEADdebian/016-1.2master
nl_object_ops'" (Closes: 713454)
-rw-r--r--debian/changelog11
-rw-r--r--debian/patches/fix-ftbfs-nl_object_ops.patch25
-rw-r--r--debian/patches/series1
3 files changed, 37 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7b8996c..cf6d3e9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+ntrack (016-1.2) unstable; urgency=medium
+
+ [ Dimitri John Ledkov ]
+ * Non-maintainer upload.
+
+ [ Philip Muskovac ]
+ * Fix FTBFS - "error: invalid use of undefined type 'struct
+ nl_object_ops'" (Closes: 713454)
+
+ -- Dimitri John Ledkov <xnox@ubuntu.com> Thu, 26 Dec 2013 20:05:44 +0000
+
ntrack (016-1.1) unstable; urgency=low
* Non-maintainer upload.
diff --git a/debian/patches/fix-ftbfs-nl_object_ops.patch b/debian/patches/fix-ftbfs-nl_object_ops.patch
new file mode 100644
index 0000000..7956b87
--- /dev/null
+++ b/debian/patches/fix-ftbfs-nl_object_ops.patch
@@ -0,0 +1,25 @@
+Origin: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713454
+
+Index: b/modules/ntrack-libnl.c
+===================================================================
+--- a/modules/ntrack-libnl.c
++++ b/modules/ntrack-libnl.c
+@@ -530,7 +530,8 @@ update_connectivity (ntrack_monitor_t *s
+ op_default_route_disappeared ((struct _ntrack_monitor_arch*) self, nl_info);
+ } else if (nl_info->topmost_route && topmost_route) {
+ int diff_bits;
+- if ((diff_bits = (route_obj_ops.oo_id_attrs | ROUTE_ATTR_OIF
++ struct nl_object *nl_obj = nl_object_alloc(&route_obj_ops);
++ if ((diff_bits = (nl_object_get_id_attrs(nl_obj) | ROUTE_ATTR_OIF
+ | ROUTE_ATTR_GATEWAY) &
+ nl_object_diff (OBJ_CAST (nl_info->topmost_route),
+ OBJ_CAST (topmost_route)))) {
+@@ -556,6 +557,7 @@ update_connectivity (ntrack_monitor_t *s
+ nl_info->topmost_route = topmost_route;
+ op_default_route_changed ((struct _ntrack_monitor_arch*) self, nl_info);
+ }
++ nl_object_free(nl_obj);
+ } else {
+ /* on first run of update_connectivity we emit a disappeared signal if no
+ * new topmost_route was found; in this way monitors can update their initial
+
diff --git a/debian/patches/series b/debian/patches/series
index ee4bd3f..32cf3ac 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
# put your quilt patches here
+fix-ftbfs-nl_object_ops.patch