summaryrefslogtreecommitdiff
path: root/sys
diff options
context:
space:
mode:
authorSteve M. Robbins <smr@debian.org>2012-07-18 03:57:02 +0200
committerSteve M. Robbins <smr@debian.org>2012-07-18 03:57:02 +0200
commit090c437c3ab9b07d86dff3313970cdacde925640 (patch)
tree12cbd16ff4840c7eef1406dbafba838457e9499a /sys
parent40d01c7024c55ccb31bfd182016da9982ee62f7c (diff)
use-system-portadio
=================================================================== Gbp-Pq: Name use-system-portadio.patch
Diffstat (limited to 'sys')
-rw-r--r--sys/unix/nonalsa/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys/unix/nonalsa/Makefile b/sys/unix/nonalsa/Makefile
index 6399b42..c18c7f5 100644
--- a/sys/unix/nonalsa/Makefile
+++ b/sys/unix/nonalsa/Makefile
@@ -50,13 +50,13 @@ jnyqide/jNyqIDE.jar: $(JAVASRC)
# Standard list of includes (common to all unix versions)
# Keeping portaudio and libsndfile sources local to nyquist
INCL = -Inyqsrc -Itran -Ixlisp -Isys/unix -Icmt -Iffts/src \
- -Inyqstk/include -Inyqstk -Iportaudio/include -Iportaudio/src/common \
- -Iportaudio/src/os/unix
+ -Inyqstk/include -Inyqstk
+
# system dependent stuff for nonalsa:
-AUDIOLIBS = -lsndfile -llo
+AUDIOLIBS = -lsndfile -llo -lportaudio
CC = gcc
@@ -74,7 +74,7 @@ CFLAGS = -DOSC -DCMTSTUFF $(OPT) $(INCL) \
LN = g++
AR = ar
# to enable command line editing, insert -lreadline -lcurses
-LFLAGS = $(LIBPA_PATH)/libportaudio.a $(AUDIOLIBS) -lm -lpthread -lrt
+LFLAGS = $(AUDIOLIBS) -lm -lpthread -lrt
TAGS:
find . ( -name
@@ -275,7 +275,7 @@ portaudio/Makefile:
$(LIBPA_PATH)/libportaudio.a: portaudio/Makefile
cd portaudio; make
-$(NY): $(OBJECTS) $(LIBPA_PATH)/libportaudio.a
+$(NY): $(OBJECTS)
$(LN) $(OBJECTS) $(LFLAGS) -o $(NY)
# copy appropriate system.lsp and make it read-only;