summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <dimitri.j.ledkov@intel.com>2014-10-01 10:45:36 +0100
committerDimitri John Ledkov <dimitri.j.ledkov@intel.com>2014-10-01 10:45:55 +0100
commit3bdc9d7fccdb22615080bcef9969dd788763ac99 (patch)
tree1d0b4a142c95a7996941a0da744042047969ff7d
parenta27be83e032cc08ae8614ef42889b1e3092e2dd0 (diff)
parent0928a36fed02c7c8415815d4b44649c5dfa3a276 (diff)
merge patched into master
-rw-r--r--Makefile6
-rwxr-xr-xbuild6
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/patches/0001-Use-obs-build-in-locations-and-executable-names-inst.patch61
-rw-r--r--debian/patches/series1
5 files changed, 70 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index fd3ec66..59282cd 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
VERSION=0.1
SCM=$(shell if test -d .svn; then echo svn; elif test -d .git; then echo git; fi)
DATE=$(shell date +%Y%m%d%H%M)
-BUILD=build
+BUILD=obs-build
INITVM_ARCH=$(shell bash -c '. common_functions ; build_host_arch; echo $$BUILD_INITVM_ARCH')
@@ -68,8 +68,8 @@ install:
install -m644 *.pm baselibs_global*.conf lxc.conf $(DESTDIR)$(pkglibdir)
install -m644 configs/* $(DESTDIR)$(pkglibdir)/configs
install -m644 build.1 $(DESTDIR)$(man1dir)
- ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/build
- ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/buildvc
+ ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/obs-build
+ ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/obs-buildvc
ln -sf $(pkglibdir)/unrpm $(DESTDIR)$(bindir)/unrpm
# Allow initvm to be packaged seperately from the rest of build. This
diff --git a/build b/build
index 9f9fb72..0911d61 100755
--- a/build
+++ b/build
@@ -13,8 +13,8 @@ if test "$0" = /sbin/init ; then
fi
test -z "$BUILD_DIR" -a -e /.build/build.data -a -z "$BUILD_IGNORE_2ND_STAGE" && BUILD_DIR=/.build
-test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/build
-test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/build-root
+test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/obs-build
+test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/obs-build-root
test -z "$CONFIG_DIR" && CONFIG_DIR="$BUILD_DIR/configs"
export BUILD_ARCH BUILD_HOST_ARCH BUILD_ROOT BUILD_RPMS BUILD_DIR BUILD_DEBUG
@@ -73,7 +73,7 @@ SIGNDUMMY=
DO_STATISTICS=
RUN_SHELL=
CCACHE=
-CACHE_DIR=/var/cache/build
+CACHE_DIR=/var/cache/obs-build
# This is for insserv
diff --git a/debian/.git-dpm b/debian/.git-dpm
index e23647f..1a21f7b 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-53ec11670b4264387ee59fe233e8122a39aa9174
-53ec11670b4264387ee59fe233e8122a39aa9174
+0928a36fed02c7c8415815d4b44649c5dfa3a276
+0928a36fed02c7c8415815d4b44649c5dfa3a276
53ec11670b4264387ee59fe233e8122a39aa9174
53ec11670b4264387ee59fe233e8122a39aa9174
obs-build_20140918.orig.tar.gz
diff --git a/debian/patches/0001-Use-obs-build-in-locations-and-executable-names-inst.patch b/debian/patches/0001-Use-obs-build-in-locations-and-executable-names-inst.patch
new file mode 100644
index 0000000..49a2034
--- /dev/null
+++ b/debian/patches/0001-Use-obs-build-in-locations-and-executable-names-inst.patch
@@ -0,0 +1,61 @@
+From 0928a36fed02c7c8415815d4b44649c5dfa3a276 Mon Sep 17 00:00:00 2001
+From: Dimitri John Ledkov <dimitri.j.ledkov@intel.com>
+Date: Wed, 1 Oct 2014 10:44:55 +0100
+Subject: Use obs-build in locations and executable names, instead of just
+ build.
+Organization: Intel Corporation (UK) Ltd. - Co. Reg. #1134945 - Pipers Way, Swindon SN3 1RJ
+
+Signed-off-by: Dimitri John Ledkov <dimitri.j.ledkov@intel.com>
+---
+ Makefile | 6 +++---
+ build | 6 +++---
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index fd3ec66..59282cd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ VERSION=0.1
+ SCM=$(shell if test -d .svn; then echo svn; elif test -d .git; then echo git; fi)
+ DATE=$(shell date +%Y%m%d%H%M)
+-BUILD=build
++BUILD=obs-build
+
+ INITVM_ARCH=$(shell bash -c '. common_functions ; build_host_arch; echo $$BUILD_INITVM_ARCH')
+
+@@ -68,8 +68,8 @@ install:
+ install -m644 *.pm baselibs_global*.conf lxc.conf $(DESTDIR)$(pkglibdir)
+ install -m644 configs/* $(DESTDIR)$(pkglibdir)/configs
+ install -m644 build.1 $(DESTDIR)$(man1dir)
+- ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/build
+- ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/buildvc
++ ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/obs-build
++ ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/obs-buildvc
+ ln -sf $(pkglibdir)/unrpm $(DESTDIR)$(bindir)/unrpm
+
+ # Allow initvm to be packaged seperately from the rest of build. This
+diff --git a/build b/build
+index 9f9fb72..0911d61 100755
+--- a/build
++++ b/build
+@@ -13,8 +13,8 @@ if test "$0" = /sbin/init ; then
+ fi
+
+ test -z "$BUILD_DIR" -a -e /.build/build.data -a -z "$BUILD_IGNORE_2ND_STAGE" && BUILD_DIR=/.build
+-test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/build
+-test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/build-root
++test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/obs-build
++test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/obs-build-root
+ test -z "$CONFIG_DIR" && CONFIG_DIR="$BUILD_DIR/configs"
+
+ export BUILD_ARCH BUILD_HOST_ARCH BUILD_ROOT BUILD_RPMS BUILD_DIR BUILD_DEBUG
+@@ -73,7 +73,7 @@ SIGNDUMMY=
+ DO_STATISTICS=
+ RUN_SHELL=
+ CCACHE=
+-CACHE_DIR=/var/cache/build
++CACHE_DIR=/var/cache/obs-build
+
+
+ # This is for insserv
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..9b1a32c
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Use-obs-build-in-locations-and-executable-names-inst.patch