summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHéctor Orón Martínez <zumbi@debian.org>2018-03-05 01:01:07 +0100
committerHéctor Orón Martínez <zumbi@debian.org>2019-09-01 01:59:08 +0200
commit419ff6568f341097741f8589d1a1917c6332b700 (patch)
tree528e051a6d475477d417d053bcf6ad29b0f6beeb
parent3eeef350a0b2ab91ff06148a0d76bad47388db10 (diff)
Use obs-build in locations and executable names
instead of just build. Signed-off-by: Dimitri John Ledkov <dimitri.j.ledkov@intel.com> Signed-off-by: Héctor Orón Martínez <zumbi@debian.org> Forwarded: not-needed, Debian-specific Last-Update: 2018-08-30 Gbp-Pq: Name 0001-Use-obs-build-in-locations-and-executable-names.patch
-rw-r--r--Makefile13
-rwxr-xr-xbuild6
2 files changed, 10 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 3d0c608..41f73f3 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
VERSION=0.1
SCM=$(shell if test -d .svn; then echo svn; elif test -d .git; then echo git; fi)
DATE=$(shell date +%Y%m%d%H%M)
-BUILD=build
+BUILD=obs-build
INITVM_ARCH=$(shell bash -c '. common_functions ; build_host_arch; echo $$BUILD_INITVM_ARCH')
@@ -85,11 +85,12 @@ install:
install -m644 *.pm lxc.conf $(DESTDIR)$(pkglibdir)
install -m644 configs/* $(DESTDIR)$(pkglibdir)/configs
install -m644 baselibs_configs/* $(DESTDIR)$(pkglibdir)/baselibs_configs
- install -m644 build.1 $(DESTDIR)$(man1dir)
- install -m644 vc.1 $(DESTDIR)$(man1dir)
- install -m644 unrpm.1 $(DESTDIR)$(man1dir)
- ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/build
- ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/buildvc
+ install -d $(DESTDIR)$(man1dir)
+ install -T -m644 build.1 $(DESTDIR)$(man1dir)/obs-build.1
+ install -T -m644 vc.1 $(DESTDIR)$(man1dir)/obs-buildvc.1
+ install -T -m644 unrpm.1 $(DESTDIR)$(man1dir)/unrpm.1
+ ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/obs-build
+ ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/obs-buildvc
ln -sf $(pkglibdir)/unrpm $(DESTDIR)$(bindir)/unrpm
ln -s baselibs_configs/baselibs_global.conf $(DESTDIR)$(pkglibdir)/baselibs_global.conf
ln -s baselibs_configs/baselibs_global-deb.conf $(DESTDIR)$(pkglibdir)/baselibs_global-deb.conf
diff --git a/build b/build
index bb4973a..3ecf7e8 100755
--- a/build
+++ b/build
@@ -36,8 +36,8 @@ BUILD_CONF=/etc/build.conf
test -e "$BUILD_CONF" && BUILD_DIR=/usr/lib/build
test -z "$BUILD_DIR" -a -e /.build/build.data -a -z "$BUILD_IGNORE_2ND_STAGE" && BUILD_DIR=/.build
-test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/build
-test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/build-root
+test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/obs-build
+test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/obs-build-root
test -z "$CONFIG_DIR" && CONFIG_DIR="$BUILD_DIR/configs"
export BUILD_ARCH BUILD_HOST_ARCH BUILD_ROOT BUILD_RPMS BUILD_DIR BUILD_DEBUG
@@ -107,7 +107,7 @@ CCACHE=
DLNOSIGNATURE=
BUILD_FLAVOR=
OBS_PACKAGE=
-CACHE_DIR=/var/cache/build
+CACHE_DIR=/var/cache/obs-build
RECIPE_BUILD_START_TIME=