summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Neuhauser <rneuhauser@suse.cz>2014-05-10 11:38:04 +0200
committerRoman Neuhauser <rneuhauser@suse.cz>2014-05-10 11:38:04 +0200
commit550207020e25ae45888992d6c506b908bbd1a0af (patch)
tree58994a59a4df12f05f3169a989857429bdcabbae
parente5efe0e1d38097992013f599e9ed3a78d7a2bf8c (diff)
fix makepkg failing to find install, changelog
parent breaks building packages with install script and/or changelog file. these files "should reside in the same directory as the PKGBUILD" according to PKGBUILD(5), but makepkg code handling them fails unless PKGBUILD is in the $PWD.
-rw-r--r--build-recipe-arch2
1 files changed, 1 insertions, 1 deletions
diff --git a/build-recipe-arch b/build-recipe-arch
index d89c795..3a439d9 100644
--- a/build-recipe-arch
+++ b/build-recipe-arch
@@ -33,5 +33,5 @@ recipe_resultdirs_arch() {
}
_arch_recipe_makepkg() {
- chroot $BUILD_ROOT su -lc "cd $TOPDIR/BUILD && SRCDEST=$TOPDIR/SOURCES makepkg -p ../SOURCES/PKGBUILD $*" $BUILD_USER
+ chroot $BUILD_ROOT su -lc "cd $TOPDIR/SOURCES && BUILDDIR=$TOPDIR/BUILD makepkg $*" $BUILD_USER
}