summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2020-08-06 10:50:42 +0200
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2020-08-06 10:50:42 +0200
commit7322a4a050dd4ac2b18266862552d527f9f04900 (patch)
tree7750e281d67d56eb1429029b3aa178bd0effbc6d
parent4e34859310c5c2e5d1aebbef2e58b5a3999814cf (diff)
Use Python 3 with the openstack console
-rw-r--r--debian/control4
-rw-r--r--debian/patches/python3-openstack-console.patch15
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
4 files changed, 19 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index b26f3c4..bb2cc1b 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Héctor Orón Martínez <zumbi@debian.org>
Uploaders: Andrej Shadura <andrewsh@debian.org>,
Andrew Lee (李健秋) <ajqlee@debian.org>
Build-Depends: debhelper (>= 9),
- dh-python, python-all,
+ dh-python, python3-all
libtimedate-perl
Standards-Version: 4.1.3
Vcs-Git: https://salsa.debian.org/debian/obs-build.git
@@ -15,7 +15,7 @@ Package: obs-build
Architecture: all
Depends:
${misc:Depends}, ${perl:Depends}, rpm, debootstrap, sudo, libarchive-tools,
- ${python:Depends}, python2
+ ${python3:Depends}, python3
Recommends: rpm2cpio, osc, libcrypt-ssleay-perl, e2fsprogs, xzdec
Suggests: xfsprogs, btrfs-progs
Description: scripts for building RPM/debian packages for multiple distributions
diff --git a/debian/patches/python3-openstack-console.patch b/debian/patches/python3-openstack-console.patch
new file mode 100644
index 0000000..f675a7d
--- /dev/null
+++ b/debian/patches/python3-openstack-console.patch
@@ -0,0 +1,15 @@
+From: Andrej Shadura <andrew.shadura@collabora.co.uk>
+Date: Thu, 6 Aug 2020 10:48:57 +0200
+Subject: Use Python 3 for the openstack console
+
+--- a/build-vm-openstack
++++ b/build-vm-openstack
+@@ -270,7 +270,7 @@
+ sleep 1
+ done
+
+- if ! python $BUILD_DIR/openstack-console "${WS_URL}" ; then
++ if ! python3 $BUILD_DIR/openstack-console "${WS_URL}" ; then
+ $NOVACLIENT delete $OPENSTACK_BUILD_ID
+ cleanup_and_exit 3
+ else
diff --git a/debian/patches/series b/debian/patches/series
index 47b178a..4af9838 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -9,3 +9,4 @@ debootstrap-Print-the-exact-command-we-re-going-to-run.patch
deb-Show-version-of-each-package-that-we-preinstall.patch
build-recipe-dsc-List-contents-of-build-results.patch
build-recipe-dsc-Show-information-about-the-build-chroot.patch
+python3-openstack-console.patch
diff --git a/debian/rules b/debian/rules
index 5853966..fa344e4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
include /usr/share/dpkg/default.mk
%:
- dh $@ --with python2
+ dh $@ --with python3
override_dh_install:
echo "$(DEB_VERSION)" > debian/obs-build/usr/lib/obs-build/version