summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schroeder <mls@suse.de>2014-05-13 13:45:56 +0200
committerMichael Schroeder <mls@suse.de>2014-05-13 13:45:56 +0200
commite07ef4f67e4708a242ef9acb365fd197886b76e0 (patch)
treeaa9298a626dcad13fa81347159e8708f0cfc350b
parentd41aaf2252794aa78c422574edc1dbcf40f0ee79 (diff)
improve comment handling in PKGBUILD parsing a tiny bit
It's still lacking, but this commit may help some packages.
-rw-r--r--Build/Arch.pm2
1 files changed, 1 insertions, 1 deletions
diff --git a/Build/Arch.pm b/Build/Arch.pm
index 93a04be..17680be 100644
--- a/Build/Arch.pm
+++ b/Build/Arch.pm
@@ -55,7 +55,7 @@ sub parse {
my $var = $1;
my $val = $3;
if ($2) {
- while ($val !~ s/\)\s*$//s) {
+ while ($val !~ s/\)\s*(?:#.*)?$//s) {
my $nextline = <PKG>;
last unless defined $nextline;
chomp $nextline;