summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <dimitri.j.ledkov@intel.com>2014-10-01 10:44:55 +0100
committerDimitri John Ledkov <dimitri.j.ledkov@intel.com>2014-10-25 02:37:43 +0100
commite9487df6bd6aafdc75cdb92b388d6ab49cca7a95 (patch)
treea13cd19fe5bc8d75f8b300f887f8c15e44791901
parent31ec7f8a73cc77d937267b9ae440bed5485fea1e (diff)
Use obs-build in locations and executable names, instead of just build.
Signed-off-by: Dimitri John Ledkov <dimitri.j.ledkov@intel.com>
-rw-r--r--Makefile13
-rwxr-xr-xbuild6
2 files changed, 10 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 8c84ced..94e4abb 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
VERSION=0.1
SCM=$(shell if test -d .svn; then echo svn; elif test -d .git; then echo git; fi)
DATE=$(shell date +%Y%m%d%H%M)
-BUILD=build
+BUILD=obs-build
INITVM_ARCH=$(shell bash -c '. common_functions ; build_host_arch; echo $$BUILD_INITVM_ARCH')
@@ -68,11 +68,12 @@ install:
install -m644 build-pkg build-pkg-* $(DESTDIR)$(pkglibdir)
install -m644 *.pm baselibs_global*.conf lxc.conf $(DESTDIR)$(pkglibdir)
install -m644 configs/* $(DESTDIR)$(pkglibdir)/configs
- install -m644 build.1 $(DESTDIR)$(man1dir)
- install -m644 vc.1 $(DESTDIR)$(man1dir)
- install -m644 unrpm.1 $(DESTDIR)$(man1dir)
- ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/build
- ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/buildvc
+ install -d $(DESTDIR)$(man1dir)
+ install -T -m644 build.1 $(DESTDIR)$(man1dir)/obs-build.1
+ install -T -m644 vc.1 $(DESTDIR)$(man1dir)/obs-buildvc.1
+ install -T -m644 unrpm.1 $(DESTDIR)$(man1dir)/unrpm.1
+ ln -sf $(pkglibdir)/build $(DESTDIR)$(bindir)/obs-build
+ ln -sf $(pkglibdir)/vc $(DESTDIR)$(bindir)/obs-buildvc
ln -sf $(pkglibdir)/unrpm $(DESTDIR)$(bindir)/unrpm
# Allow initvm to be packaged seperately from the rest of build. This
diff --git a/build b/build
index cdba8f8..3a5f696 100755
--- a/build
+++ b/build
@@ -31,8 +31,8 @@ if test "$0" = /sbin/init ; then
fi
test -z "$BUILD_DIR" -a -e /.build/build.data -a -z "$BUILD_IGNORE_2ND_STAGE" && BUILD_DIR=/.build
-test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/build
-test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/build-root
+test -z "$BUILD_DIR" && BUILD_DIR=/usr/lib/obs-build
+test -z "$BUILD_ROOT" && BUILD_ROOT=/var/tmp/obs-build-root
test -z "$CONFIG_DIR" && CONFIG_DIR="$BUILD_DIR/configs"
export CHROOT="chroot $BUILD_ROOT"
@@ -94,7 +94,7 @@ DO_STATISTICS=
RUN_SHELL=
CCACHE=
DLNOSIGNATURE=
-CACHE_DIR=/var/cache/build
+CACHE_DIR=/var/cache/obs-build
# This is for insserv