summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2020-08-12 15:35:00 +0200
committerStéphane Glondu <glondu@debian.org>2020-08-12 15:50:10 +0200
commit5627582b0aa31a7058ec687d4ed3afd51684d191 (patch)
tree533f8ae8c7ee18d9362884d8666b85bd57324fa9
parent7377d5087b7dd08f4252734270c0db854d40ab5f (diff)
Fix FTBFS with OCaml 4.08.1
Bug-Debian: https://bugs.debian.org/944600 Gbp-Pq: Name 0001-Fix-FTBFS-with-OCaml-4.08.1.patch
-rw-r--r--Makefile2
-rw-r--r--_tags1
-rw-r--r--melt/mlpost_on.ml2
-rw-r--r--melt/tool.ml2
-rw-r--r--meltpp/plugin_private.ml1
5 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 99ef55e..fb5dd93 100644
--- a/Makefile
+++ b/Makefile
@@ -100,4 +100,4 @@ dist: noob.makefile
.PHONY: default fast world clean doc all world.10 bench test check dist check-ocamlbuild
Config: configure.ml totoconf.ml
- ocaml configure.ml
+ ocaml -unsafe-string configure.ml
diff --git a/_tags b/_tags
index fe6cb21..10d8403 100644
--- a/_tags
+++ b/_tags
@@ -1,3 +1,4 @@
<melt/tool.*>: use_unix, use_str
<latop/latop.*>: use_unix, use_str
<meltpp/*.*>: use_unix, use_dynlink, use_str
+true: unsafe_string
diff --git a/melt/mlpost_on.ml b/melt/mlpost_on.ml
index e63cc8b..f1f650b 100644
--- a/melt/mlpost_on.ml
+++ b/melt/mlpost_on.ml
@@ -82,7 +82,7 @@ let mlpost_gen includegraphics ?(mode = mode) ?file f =
in
let ext = match mode with
| `Pdf -> ".mps"
- | `Ps -> ".1"
+ | `Ps -> ".mps"
| `Cairo -> ".pdf"
| `Mps -> ".mps"
in
diff --git a/melt/tool.ml b/melt/tool.ml
index 2ff5cd1..5971ced 100644
--- a/melt/tool.ml
+++ b/melt/tool.ml
@@ -236,7 +236,7 @@ let ml_to_tex f =
let meltlibo = libopt "melt" in
let mlpostlibo =
if Melt.compiled_with_mlpost then libopt "mlpost" else "" in
- let strlibo = libopt "str" in
+ let strlibo = "" in
let unixlibo = libopt "unix" in
let ext = if !native then "native" else "byte" in
let ocamlc_includes = match !includes with
diff --git a/meltpp/plugin_private.ml b/meltpp/plugin_private.ml
index 6f05a05..3d0a366 100644
--- a/meltpp/plugin_private.ml
+++ b/meltpp/plugin_private.ml
@@ -60,7 +60,6 @@ let load_plugin =
let init = ref false in
fun name ->
if not !init then begin
- Dynlink.init ();
Dynlink.prohibit ["Ast"; "Lexer"; "Parser"; "Plugin_private"];
init := true;
end;