summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2019-09-07 10:47:12 +0200
committerStephane Glondu <steph@glondu.net>2019-09-07 10:47:12 +0200
commit996f965b287b854be3fe67b8d19764ae31608a70 (patch)
tree7b665cd590796e91ed78e15db137d4060ab69402
parenta8dc97dff93199b77ace7b026ac76ac0a907fea0 (diff)
Refresh patches
-rw-r--r--debian/patches/0002-Use-the-Debian-prefix-for-building.patch4
-rw-r--r--debian/patches/0003-Fix-the-build-on-non-native-architectures.patch4
-rw-r--r--debian/patches/0004-install-stublibs.patch8
3 files changed, 11 insertions, 5 deletions
diff --git a/debian/patches/0002-Use-the-Debian-prefix-for-building.patch b/debian/patches/0002-Use-the-Debian-prefix-for-building.patch
index 35c9ffd..729704e 100644
--- a/debian/patches/0002-Use-the-Debian-prefix-for-building.patch
+++ b/debian/patches/0002-Use-the-Debian-prefix-for-building.patch
@@ -9,6 +9,8 @@ Forwarded: not-needed
CONFIGME | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
+diff --git a/CONFIGME b/CONFIGME
+index 96ecf91..f80b6a5 100644
--- a/CONFIGME
+++ b/CONFIGME
@@ -35,7 +35,7 @@
@@ -29,7 +31,7 @@ Forwarded: not-needed
# Prefix for the locale files (at run-time)
localeprefix=${prefix}/share/locale
-@@ -69,12 +69,12 @@ ocaml_libraryprefix=$(ocamlc -where || e
+@@ -69,12 +69,12 @@ ocaml_libraryprefix=$(ocamlc -where || exit -1)
# library or into ${ocaml_libraryprefix}, but you can change it if you really
# want to install into a different, custom prefix.
# *No* trailing slash should be included.
diff --git a/debian/patches/0003-Fix-the-build-on-non-native-architectures.patch b/debian/patches/0003-Fix-the-build-on-non-native-architectures.patch
index 3eee68d..45d1837 100644
--- a/debian/patches/0003-Fix-the-build-on-non-native-architectures.patch
+++ b/debian/patches/0003-Fix-the-build-on-non-native-architectures.patch
@@ -12,9 +12,11 @@ Forwarded: https://bugs.launchpad.net/ocamlbricks/+bug/1130098
Makefile.d/ocamlmklib_wrapper.sh | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
+diff --git a/Makefile.d/ocamlmklib_wrapper.sh b/Makefile.d/ocamlmklib_wrapper.sh
+index 420dfca..ca08798 100755
--- a/Makefile.d/ocamlmklib_wrapper.sh
+++ b/Makefile.d/ocamlmklib_wrapper.sh
-@@ -40,5 +40,9 @@ CMX=$(ocamlobjinfo _build/ocamlbricks.cm
+@@ -40,5 +40,9 @@ CMX=$(ocamlobjinfo _build/ocamlbricks.cma | awk '/Unit name/{x=tolower(substr($3
cd _build/
echo "Rebuilding library with ocamlmklib..."
echo '---'; set -x; ocamlc -a -linkall -dllib -locamlbricks_stubs -o ocamlbricks.cma $INCLUDES $CMO; set +x
diff --git a/debian/patches/0004-install-stublibs.patch b/debian/patches/0004-install-stublibs.patch
index 71167a3..c762b1d 100644
--- a/debian/patches/0004-install-stublibs.patch
+++ b/debian/patches/0004-install-stublibs.patch
@@ -3,12 +3,14 @@ Date: Thu, 20 Apr 2017 13:10:42 +0200
Subject: Install stublibs
---
- Makefile | 9 ++++-----
- 1 file changed, 4 insertions(+), 5 deletions(-)
+ Makefile | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+diff --git a/Makefile b/Makefile
+index df38c1e..867e7e7 100644
--- a/Makefile
+++ b/Makefile
-@@ -443,10 +443,9 @@ install-libraries: libraries install-lib
+@@ -443,10 +443,9 @@ install-libraries: libraries install-libraries-local
_build/*.cma _build/*.cmxa _build/*.a _build/*.so \
`find _build/ -name \*.cm\[iox\] | grep -v /myocamlbuild` \
`find _build/ -name \*.mli | grep -v /myocamlbuild` \