summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2022-08-16 14:14:59 -0700
committerSean Whitton <spwhitton@spwhitton.name>2022-08-16 14:14:59 -0700
commit27f6297e5f65cdf896497c4313895871cd59b458 (patch)
treeea730f9bbce3210ddd264f11e280ac4a8ea97ed9
parent2f67e453a9ecbaf224183e0f10c50ed33c61b1c4 (diff)
Commit Debian 3.0 (quilt) metadata
[dgit (9.14) quilt-fixup]
-rw-r--r--debian/patches/debian-changes44
1 files changed, 17 insertions, 27 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index 1fc814fe..574fc33b 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -9,9 +9,9 @@ patches. To obtain a patch queue for package version 1.2.3-1:
% git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
---- ocrmypdf-13.4.3+dfsg.orig/docs/conf.py
-+++ ocrmypdf-13.4.3+dfsg/docs/conf.py
-@@ -100,7 +100,7 @@ except ModuleNotFoundError:
+--- ocrmypdf-13.7.0+dfsg.orig/docs/conf.py
++++ ocrmypdf-13.7.0+dfsg/docs/conf.py
+@@ -102,7 +102,7 @@ except ModuleNotFoundError:
from importlib.metadata import version as package_version
# The full version, including alpha/beta/rc tags.
@@ -20,9 +20,9 @@ See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
version = '.'.join(release.split('.')[:2])
---- ocrmypdf-13.4.3+dfsg.orig/docs/index.rst
-+++ ocrmypdf-13.4.3+dfsg/docs/index.rst
-@@ -15,7 +15,6 @@ image processing and OCR to existing PDF
+--- ocrmypdf-13.7.0+dfsg.orig/docs/index.rst
++++ ocrmypdf-13.7.0+dfsg/docs/index.rst
+@@ -19,7 +19,6 @@ image processing and OCR to existing PDF
introduction
release_notes
@@ -30,9 +30,9 @@ See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
optimizer
languages
jbig2
---- ocrmypdf-13.4.3+dfsg.orig/docs/languages.rst
-+++ ocrmypdf-13.4.3+dfsg/docs/languages.rst
-@@ -22,9 +22,6 @@ English is assumed by default unless oth
+--- ocrmypdf-13.7.0+dfsg.orig/docs/languages.rst
++++ ocrmypdf-13.7.0+dfsg/docs/languages.rst
+@@ -26,9 +26,6 @@ English is assumed by default unless oth
For Linux users, you can often find packages that provide language
packs:
@@ -42,7 +42,7 @@ See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
.. code-block:: bash
# Display a list of all Tesseract language packs
-@@ -35,69 +32,5 @@ Debian and Ubuntu users
+@@ -39,69 +36,5 @@ Debian and Ubuntu users
You can then pass the ``-l LANG`` argument to OCRmyPDF to give a hint as
to what languages it should search for. Multiple languages can be
@@ -114,9 +114,9 @@ See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
-``C:\\Program Files\\Tesseract-OCR\\tessdata`` (or wherever Tesseract OCR is installed).
+requested using either ``-l eng+fre`` (English and French) or
+``-l eng -l fre``.
---- ocrmypdf-13.4.3+dfsg.orig/pyproject.toml
-+++ ocrmypdf-13.4.3+dfsg/pyproject.toml
-@@ -81,7 +81,6 @@ known_third_party = [
+--- ocrmypdf-13.7.0+dfsg.orig/pyproject.toml
++++ ocrmypdf-13.7.0+dfsg/pyproject.toml
+@@ -79,7 +79,6 @@ known_third_party = [
minversion = "6.0"
norecursedirs = ["lib", ".pc", ".git", "venv", "output", "cache", "resources"]
testpaths = ["tests"]
@@ -124,19 +124,9 @@ See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
markers = ["slow"]
filterwarnings = ["ignore:.*XMLParser.*:DeprecationWarning"]
---- ocrmypdf-13.4.3+dfsg.orig/setup.py
-+++ ocrmypdf-13.4.3+dfsg/setup.py
-@@ -11,7 +11,6 @@ from setuptools import setup
- setup(
- setup_requires=[ # can be removed whenever we can drop pip 9 support
- 'setuptools_scm', # so that version will work
-- 'setuptools_scm_git_archive', # enable version from github tarballs
- ],
- use_scm_version={'version_scheme': 'post-release'},
- )
---- ocrmypdf-13.4.3+dfsg.orig/src/ocrmypdf/cli.py
-+++ ocrmypdf-13.4.3+dfsg/src/ocrmypdf/cli.py
-@@ -118,7 +118,7 @@ minimize the number of changes made to y
+--- ocrmypdf-13.7.0+dfsg.orig/src/ocrmypdf/cli.py
++++ ocrmypdf-13.7.0+dfsg/src/ocrmypdf/cli.py
+@@ -126,7 +126,7 @@ minimize the number of changes made to y
If OCRmyPDF is given an image file as input, it will attempt to convert the
image to a PDF before processing. For more control over the conversion of
@@ -145,7 +135,7 @@ See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
For example, this command uses img2pdf to convert all .png files beginning
with the 'page' prefix to a PDF, fitting each image on A4-sized paper, and
-@@ -126,8 +126,9 @@ sending the result to OCRmyPDF through a
+@@ -134,8 +134,9 @@ sending the result to OCRmyPDF through a
img2pdf --pagesize A4 page*.png | ocrmypdf - myfile.pdf