summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Laboissière <rafael@debian.org>2022-07-12 11:45:07 -0300
committerRafael Laboissière <rafael@debian.org>2022-07-12 11:45:07 -0300
commitb72c11e3ca8a6a7faacdcd38de0c772e51702ed3 (patch)
treed992e74a23e01fc95c813ba35a69a65637160b79
parentf11088148fd3d61db59f8af97c15cc30af358cc3 (diff)
Add distclean rule to src/Makefile.in
Forwarded: https://savannah.gnu.org/bugs/index.php?62753 Last-Update: 2022-07-11 Besides the addition of the distclean target, the clean rule has been modified by adding the "-" prefix to the rm command, such that make will not stop if the files to be cleaned do not exist. Also, a .PHONY target has been added. Gbp-Pq: Name add-distclean-target.patch
-rw-r--r--src/Makefile.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.in b/src/Makefile.in
index 295bc30..a0177d3 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -9,4 +9,9 @@ gdalread.oct : gdalread.cc misc.cpp
$(MKOCTFILE) $(DEFS) $(CXXFLAGS) $(GDAL_CFLAGS) $(GDAL_LIBS) -o $@ $^
clean:
- rm misc.o gdalread.o gdalread.oct
+ -rm misc.o gdalread.o gdalread.oct
+
+distclean: clean
+ -rm Makefile config.h config.log config.status
+
+.PHONY: clean distclean