summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Laboissière <rafael@debian.org>2020-02-08 18:34:59 -0300
committerRafael Laboissière <rafael@debian.org>2020-02-08 18:34:59 -0300
commitbd5eafdc26bfa561d0ee90bedccffe53b007efa8 (patch)
treedd075e124df15086c38bae449c719c3a9b30bbe6
parentb9c223bd4cd58caccb5ad784e215e8dbdc46e243 (diff)
New upstream version 0.3.6
-rw-r--r--DESCRIPTION8
-rw-r--r--Makefile7
-rw-r--r--NEWS5
-rw-r--r--src/Makefile.in2
-rwxr-xr-xsrc/configure18
-rw-r--r--src/configure.ac2
-rw-r--r--src/optiminterp.cc9
7 files changed, 30 insertions, 21 deletions
diff --git a/DESCRIPTION b/DESCRIPTION
index ecadf65..98d686e 100644
--- a/DESCRIPTION
+++ b/DESCRIPTION
@@ -1,10 +1,10 @@
Name: optiminterp
-Version: 0.3.5
-Date: 2018-04-15
-Author: Alexander Barth <barth.alexander@gmail.com>, Aida Alvera-Azcárate <aalvera@marine.usf.edu>
+Version: 0.3.6
+Date: 2020-01-03
+Author: Alexander Barth <barth.alexander@gmail.com>, Aida Alvera-Azcárate <aalvera@marine.usf.edu>
Maintainer: Alexander Barth <barth.alexander@gmail.com>, John Donoghue <john.donoghue@ieee.org>
Title: optiminterp
Description: An optimal interpolation toolbox for octave. This package provides functions to perform a n-dimensional optimal interpolations of arbitrarily distributed data points.
-Depends: octave (>= 2.9.9)
+Depends: octave (>= 3.6.0)
License: GPLv3+
Url: http://octave.sf.net
diff --git a/Makefile b/Makefile
index b3fe537..120b7a1 100644
--- a/Makefile
+++ b/Makefile
@@ -214,10 +214,9 @@ doctest: $(install_stamp)
## Test package.
octave_test_commands = \
-' dirs = {"inst", "src"}; \
- dirs(cellfun (@ (x) ! isdir (x), dirs)) = []; \
- if (isempty (dirs)) error ("no \"inst\" or \"src\" directory"); exit (1); \
- else __run_test_suite__ (dirs, {}); endif '
+' pkgs = pkg("list", "$(package)"); \
+ dirs = {pkgs{1}.dir}; \
+ __run_test_suite__ (dirs, {}); '
## the following works, too, but provides no overall summary output as
## __run_test_suite__ does:
##
diff --git a/NEWS b/NEWS
index 79a492d..f23d675 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,8 @@
+Summary of important user-visible changes for optiminterp 0.3.6:
+-------------------------------------------------------------------
+
+ ** remove use of depreciated f77_exception_encountered
+
Summary of important user-visible changes for optiminterp 0.3.5:
-------------------------------------------------------------------
diff --git a/src/Makefile.in b/src/Makefile.in
index 4c56e3a..f13dded 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -62,3 +62,5 @@ optiminterp_wrapper.o: optiminterp_wrapper.F90 optimal_interpolation.o
clean:
rm -f *.o *.oct *~ *.mod
+
+.NOTPARALLEL:
diff --git a/src/configure b/src/configure
index af67eac..2f587a6 100755
--- a/src/configure
+++ b/src/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for octave optiminterp 0.3.5.
+# Generated by GNU Autoconf 2.69 for octave optiminterp 0.3.6.
#
#
# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -576,8 +576,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='octave optiminterp'
PACKAGE_TARNAME='octave-optiminterp'
-PACKAGE_VERSION='0.3.5'
-PACKAGE_STRING='octave optiminterp 0.3.5'
+PACKAGE_VERSION='0.3.6'
+PACKAGE_STRING='octave optiminterp 0.3.6'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@@ -1206,7 +1206,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures octave optiminterp 0.3.5 to adapt to many kinds of systems.
+\`configure' configures octave optiminterp 0.3.6 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1269,7 +1269,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of octave optiminterp 0.3.5:";;
+ short | recursive ) echo "Configuration of octave optiminterp 0.3.6:";;
esac
cat <<\_ACEOF
@@ -1350,7 +1350,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-octave optiminterp configure 0.3.5
+octave optiminterp configure 0.3.6
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1443,7 +1443,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by octave optiminterp $as_me 0.3.5, which was
+It was created by octave optiminterp $as_me 0.3.6, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -3530,7 +3530,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by octave optiminterp $as_me 0.3.5, which was
+This file was extended by octave optiminterp $as_me 0.3.6, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -3583,7 +3583,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-octave optiminterp config.status 0.3.5
+octave optiminterp config.status 0.3.6
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/src/configure.ac b/src/configure.ac
index 5eb9aed..f896fe9 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -5,7 +5,7 @@
dnl autoconf 2.13 certainly doesn't work! What is the minimum requirement?
AC_PREREQ(2.2)
-AC_INIT([octave optiminterp],[0.3.5])
+AC_INIT([octave optiminterp],[0.3.6])
dnl Kill caching --- this ought to be the default
define([AC_CACHE_LOAD], )dnl
diff --git a/src/optiminterp.cc b/src/optiminterp.cc
index 3a886dc..fb08490 100644
--- a/src/optiminterp.cc
+++ b/src/optiminterp.cc
@@ -1,5 +1,5 @@
// Copyright (C) 2005 Alexander Barth <barth.alexander@gmail.com>
-// 2017 John Donoghue <john.david.donoghue@gmail.com>
+// 2017,2019 John Donoghue <john.david.donoghue@gmail.com>
//
// This program is free software; you can redistribute it and/or modify it under
// the terms of the GNU General Public License as published by the Free Software
@@ -130,10 +130,13 @@ have a error variance of one. The error variances of the observations need to be
( n,nf,gn,on,nparam,ox.fortran_vec(),of.fortran_vec(),ovar.fortran_vec(),
param.fortran_vec(),m,gx.fortran_vec(),gf.fortran_vec(),gvar.fortran_vec()));
- if (f77_exception_encountered) {
+#if defined (F77_XFCN_ERROR)
+ if (f77_exception_encountered)
+ {
error ("unrecoverable error in optiminterp");
return retval;
- }
+ }
+#endif
gf = gf.transpose();