summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Laboissiere <rafael@debian.org>2023-09-16 16:40:28 -0300
committerRafael Laboissière <rafael@debian.org>2023-09-16 16:40:28 -0300
commit4581d0d9690cee416f85b4b049d331cca46db680 (patch)
treea993d869976eee048a3fa587f5f17252c6f9deb2
parent276e5ab19cb688648561672a943aec41cde62f87 (diff)
Include necessary iostream header
Forwarded: https://savannah.gnu.org/bugs/index.php?57001 Last-Update: 2023-09-16 Gbp-Pq: Name include-iostream.patch
-rw-r--r--src/configure.ac4
-rw-r--r--src/error-helpers.cc1
2 files changed, 3 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 4b5183a..0ee1401 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -268,8 +268,8 @@ dnl separate test
[octave::mach_info],
[[int f = octave::mach_info::flt_fmt_unknown;]],
[OCTAVE__MACH_INFO],
- [],
- []
+ [#include <iostream>],
+ [#include <iostream>]
],
[dnl
diff --git a/src/error-helpers.cc b/src/error-helpers.cc
index 4d08fb1..9630e8c 100644
--- a/src/error-helpers.cc
+++ b/src/error-helpers.cc
@@ -20,6 +20,7 @@ along with this program; If not, see <http://www.gnu.org/licenses/>.
#include <octave/oct.h>
#include "error-helpers.h"
+#include <iostream>
// call verror
#ifdef HAVE_OCTAVE_VERROR_ARG_EXC