summaryrefslogtreecommitdiff
path: root/src/core/PrivateTypes.h
diff options
context:
space:
mode:
authorMatteo F. Vescovi <mfv.debian@gmail.com>2013-08-20 09:53:19 +0100
committerMatteo F. Vescovi <mfv.debian@gmail.com>2013-08-20 09:53:19 +0100
commit66e5d9e2915733247bca47d077414ec2594aedad (patch)
treef4070a31bf015e159dadd34378cda703d8f6edea /src/core/PrivateTypes.h
opencolorio (1.0.8~dfsg0-2) unstable; urgency=low
* debian/rules: get-orig-source stuff added * debian/rules: useless dh addon removed * debian/rules: License.txt duplicate removed * debian/rules: SSE optimization disabled (Closes: #719174) * debian/libopencolorio1.symbols: file removed (Closes: #719175) # imported from the archive
Diffstat (limited to 'src/core/PrivateTypes.h')
-rw-r--r--src/core/PrivateTypes.h54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/core/PrivateTypes.h b/src/core/PrivateTypes.h
new file mode 100644
index 0000000..4f0b1ee
--- /dev/null
+++ b/src/core/PrivateTypes.h
@@ -0,0 +1,54 @@
+/*
+Copyright (c) 2003-2010 Sony Pictures Imageworks Inc., et al.
+All Rights Reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+* Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+* Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+* Neither the name of Sony Pictures Imageworks nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+*/
+
+
+#ifndef INCLUDED_OCIO_PRIVATE_TYPES_H
+#define INCLUDED_OCIO_PRIVATE_TYPES_H
+
+#include <OpenColorIO/OpenColorIO.h>
+
+#include <map>
+#include <set>
+#include <vector>
+
+OCIO_NAMESPACE_ENTER
+{
+ // Stl types of OCIO classes
+ typedef std::map<std::string, std::string> StringMap;
+ typedef std::vector<std::string> StringVec;
+ typedef std::set<std::string> StringSet;
+
+ typedef std::vector<ConstTransformRcPtr> ConstTransformVec;
+ typedef std::vector<ColorSpaceRcPtr> ColorSpaceVec;
+ typedef std::vector<LookRcPtr> LookVec;
+
+ typedef std::vector<TransformDirection> TransformDirectionVec;
+}
+OCIO_NAMESPACE_EXIT
+
+#endif