summaryrefslogtreecommitdiff
path: root/src/apps/ociolutimage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/apps/ociolutimage/CMakeLists.txt')
-rw-r--r--src/apps/ociolutimage/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/apps/ociolutimage/CMakeLists.txt b/src/apps/ociolutimage/CMakeLists.txt
new file mode 100644
index 0000000..86bc0e7
--- /dev/null
+++ b/src/apps/ociolutimage/CMakeLists.txt
@@ -0,0 +1,16 @@
+if (OIIO_FOUND)
+ include_directories(
+ ${CMAKE_SOURCE_DIR}/export/
+ ${CMAKE_BINARY_DIR}/export/
+ ${CMAKE_SOURCE_DIR}/src/apps/share/
+ ${OIIO_INCLUDES}
+ )
+
+ file(GLOB_RECURSE share_src_files "${CMAKE_SOURCE_DIR}/src/apps/share/*.cpp")
+
+ add_executable(ociolutimage ${share_src_files} main.cpp)
+
+ target_link_libraries(ociolutimage ${OIIO_LIBRARIES} OpenColorIO dl)
+
+ install(TARGETS ociolutimage DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)
+endif()