summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2019-10-19 17:02:16 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2019-10-19 17:02:16 +0000
commit73c785f7ae2a8fcf0bf4f679de5ecc5169d9a82b (patch)
treec6e1ce48cbde9ac7c0370eed663c108932398a8c
parentecca1acd8421a81143cef3027e7600370295a56c (diff)
Remove Python2 package
-rw-r--r--debian/control19
-rw-r--r--debian/python-openems.install2
-rwxr-xr-xdebian/rules7
3 files changed, 1 insertions, 27 deletions
diff --git a/debian/control b/debian/control
index 91d921d..943f11f 100644
--- a/debian/control
+++ b/debian/control
@@ -15,11 +15,9 @@ Build-Depends: debhelper (>= 11),
# It is called octave-pkg-dev in stretch
# and dh-octave in sid
dh-octave | octave-pkg-dev,
- cython,
cython3,
chrpath,
dh-python,
- python-all,
python3-all,
txt2man
Standards-Version: 4.3.0
@@ -134,23 +132,6 @@ Description: Octave interface for openems
openEMS is a simulator for electromagnetic problems using
the FDTD algorithm.
-Package: python-openems
-Architecture: any
-Section: python
-Depends: ${shlibs:Depends},
- ${misc:Depends},
- ${python:Depends},
- openems (= ${binary:Version}),
- python,
- python-h5py,
- python-matplotlib
-Description: Python interface for openems
- This package contains the Python-files needed for
- openEMS.
- .
- openEMS is a simulator for electromagnetic problems using
- the FDTD algorithm.
-
Package: python3-openems
Architecture: any
Section: python
diff --git a/debian/python-openems.install b/debian/python-openems.install
deleted file mode 100644
index 4e2369e..0000000
--- a/debian/python-openems.install
+++ /dev/null
@@ -1,2 +0,0 @@
-openEMS/python/debian/tmp/usr/lib/python2* usr/lib/
-CSXCAD/python/debian/tmp/usr/lib/python2* usr/lib/
diff --git a/debian/rules b/debian/rules
index 5fb405b..e956988 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,13 +18,12 @@ OCTAVE_HOSTTYPE = $(shell octave-config -p CANONICAL_HOST_TYPE)
OCTAVE_API_VERSION = $(shell octave-config -p API_VERSION)
OCTAVE_FULLBPATH = $(OCTAVE_BPATH)/openems-0.0.35/$(OCTAVE_HOSTTYPE)-$(OCTAVE_API_VERSION)
-PYTHON2VERSIONS := $(shell pyversions -s -v)
PYTHON3VERSIONS := $(shell py3versions -s -v)
export CXXFLAGS := $(CXXFLAGS) -DSSE_CORRECT_DENORMALS=0
%:
- dh $@ --with python2,python3
+ dh $@ --with python3
# Since some sub-folders depend on other sub-folders to be installed before
@@ -51,9 +50,7 @@ override_dh_auto_install:
chrpath -d debian/tmp/usr/bin/AppCSXCAD
chrpath -d debian/tmp/usr/bin/nf2ff
chrpath -d debian/tmp/usr/bin/openEMS
- cd CSXCAD/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --install
cd CSXCAD/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --install
- cd openEMS/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --install
cd openEMS/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --install
override_dh_auto_clean:
@@ -63,8 +60,6 @@ override_dh_auto_clean:
$(RM) -r openEMS/build || true
$(RM) -r AppCSXCAD/build || true
$(RM) debian/man/*.1
- cd CSXCAD/python && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --clean
- cd openEMS/python && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --clean
cd CSXCAD/python && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --clean
cd openEMS/python && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --clean
$(RM) -r CSXCAD/python/debian