summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-11-23 21:23:59 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2018-11-23 21:23:59 +0100
commitc400a7096632b7c4507021d0f80c2216be309402 (patch)
treeb2add66c606ef3b050b187972b32c36ebd0d7572
parent1e9edbc6c49192d1d6f97c133f0a7c010afd7f36 (diff)
Cherry-pick fix from upstream for build on machines without SSE
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0007-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch47
-rw-r--r--debian/patches/series1
3 files changed, 55 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ea08ac1..a5068cc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+openems (0.0.35+dfsg.1-2) unstable; urgency=medium
+
+ * debian/patches0007-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch
+ - Cherry-pick fix from upstream: a5a1dca8324aa12dfbf8e268fbc06c2310b91c69
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Fri, 23 Nov 2018 21:22:01 +0100
+
openems (0.0.35+dfsg.1-1) unstable; urgency=low
* Initial release (Closes: #830109)
diff --git a/debian/patches/0007-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch b/debian/patches/0007-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch
new file mode 100644
index 0000000..1fa3e9f
--- /dev/null
+++ b/debian/patches/0007-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch
@@ -0,0 +1,47 @@
+From: =?utf-8?q?Stefan_Br=C3=BCns?= <stefan.bruens@rwth-aachen.de>
+Date: Tue, 27 Mar 2018 02:28:22 +0200
+Subject: Guard xmmintrin.h include so it is only used when necessary
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+The x86/SSE specific code for Flush-To-Zero is only used when
+SSE_CORRECT_DENORMALS is not defined. Guarding the include allows the
+code to compile on e.g. ARM.
+
+Signed-off-by: Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
+---
+ openEMS/FDTD/engine_multithread.cpp | 3 +++
+ openEMS/FDTD/engine_sse.cpp | 3 +++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/openEMS/FDTD/engine_multithread.cpp b/openEMS/FDTD/engine_multithread.cpp
+index 7370198..7ebe0d7 100644
+--- a/openEMS/FDTD/engine_multithread.cpp
++++ b/openEMS/FDTD/engine_multithread.cpp
+@@ -32,7 +32,10 @@
+ #include "boost/date_time/posix_time/posix_time.hpp"
+ #include "boost/date_time/gregorian/gregorian.hpp"
+ #include <iomanip>
++
++#ifndef SSE_CORRECT_DENORMALS
+ #include <xmmintrin.h>
++#endif
+
+ //! \brief construct an Engine_Multithread instance
+ //! it's the responsibility of the caller to free the returned pointer
+diff --git a/openEMS/FDTD/engine_sse.cpp b/openEMS/FDTD/engine_sse.cpp
+index 660e6d6..2e06685 100644
+--- a/openEMS/FDTD/engine_sse.cpp
++++ b/openEMS/FDTD/engine_sse.cpp
+@@ -15,7 +15,10 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#ifndef SSE_CORRECT_DENORMALS
+ #include <xmmintrin.h>
++#endif
++
+ #include "engine_sse.h"
+
+ //! \brief construct an Engine_sse instance
diff --git a/debian/patches/series b/debian/patches/series
index 6107a1e..5267054 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -4,3 +4,4 @@
0004-link-more.patch
0005-Deletede-CVS-dir-lintian.patch
0006-Don-t-exit-from-library.patch
+0007-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch