summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Bourg <ebourg@apache.org>2016-05-31 17:24:39 +0200
committerEmmanuel Bourg <ebourg@apache.org>2016-05-31 17:24:39 +0200
commita1312bec8bdcf6ceb4076351c311b13b5b17b4fb (patch)
tree40058eb372ca80e5b5cfbfad75a6c726c5c21727
parente8a6fdf1175e69d756430829514e03560438d483 (diff)
Build with the DH sequencer instead of CDBS
-rw-r--r--debian/changelog1
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules12
3 files changed, 9 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index b4942cc..cec2cc4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
openhft-lang (6.1.4-2) UNRELEASED; urgency=medium
+ * Build with the DH sequencer instead of CDBS
* Standards-Version updated to 3.9.8 (no changes)
* Use a secure Vcs-Git URL
diff --git a/debian/control b/debian/control
index d9ced35..8ebbb25 100644
--- a/debian/control
+++ b/debian/control
@@ -3,14 +3,13 @@ Section: java
Priority: optional
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Uploaders: Emmanuel Bourg <ebourg@apache.org>
-Build-Depends: cdbs,
- debhelper (>= 9),
+Build-Depends: debhelper (>= 9),
default-jdk,
junit4,
libeasymock-java,
libmaven-bundle-plugin-java,
libopenhft-compiler-java,
- maven-debian-helper (>= 1.5),
+ maven-debian-helper (>= 2.0),
zip
Standards-Version: 3.9.8
Vcs-Git: https://anonscm.debian.org/git/pkg-java/openhft-lang.git
diff --git a/debian/rules b/debian/rules
index 83ce3a5..1c4a7b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,16 +1,16 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/maven.mk
+%:
+ dh $@ --buildsystem=maven
-JAVA_HOME := /usr/lib/jvm/default-java
+override_dh_auto_install:
+ dh_auto_install
-common-install-indep::
# Remove an unused pom
rm -Rf debian/libopenhft-lang-java/usr/share/maven-repo/net/openhft/Java-Lang
-
+
# Remove the Jetbrains annotations
zip --delete debian/libopenhft-lang-java/usr/share/java/openhft-lang.jar org*
get-orig-source:
- uscan --download-current-version --force-download --no-symlink
+ uscan --download-current-version --force-download --repack --compression xz