summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-10-13 12:33:25 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-10-13 12:33:25 +0200
commit0c1a4fb4fd12d0af97f439e35f851d704fe91ae7 (patch)
treee4e138e8a358077de57f190499daad6d334c439b
parent21b2555812157fef0e13e03310128d8eb05e6556 (diff)
Fix some lintians
-rw-r--r--debian/changelog5
-rw-r--r--debian/copyright26
-rw-r--r--debian/patches/0003-Remove-Encoding-field-in-desktop-file.patch19
-rw-r--r--debian/patches/0004-Spelling-fixes.patch44
-rw-r--r--debian/patches/series2
5 files changed, 80 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index 2b1eabc..f91281f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,7 +18,10 @@ oregano (0.84.40+dfsg.1-1) UNRELEASED; urgency=medium
- HTTPS URL for Format field
- Exclude a few model files with slightly troublesome licenses.
* debian/gbp.conf: Added to enforce pristine-tar
- * debian/patches: Refreshed patches and deleted outdated ones
+ * debian/patches:
+ - Refreshed patches and deleted outdated ones
+ - New patch: 0003-Remove-Encoding-field-in-desktop-file.patch
+ - New patch: debian/patches/0004-Spelling-fixes.patch
* debian/README.source: Describe why the tarball is repacked
* debian/repack-waf:
- New script used by uscan/watch to repack tarball without
diff --git a/debian/copyright b/debian/copyright
index 5a17b60..aefad6b 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -13,22 +13,17 @@ Copyright: 1989-2005 Free Software Foundation, Inc
2017 Guido Trentalancia
License: GPL-2+
-Files: INSTALL
- data/mime/Makefile.in
- po/Makefile.in.in
-Copyright: 2004-2008, Rodney Dawes <dobey.pwns@gmail.com>
- 1995-1997, Ulrich Drepper <drepper@gnu.ai.mit.edu>
-License: Permissive
- Copying and distribution of this file, with or without modification,
- are permitted in any medium without royalty provided the copyright
- notice and this notice are preserved. This file is offered as-is,
- without warranty of any kind.
-
-Files: help/*
+Files: po/*
Copyright: 1999-2002, Richard Hult
- 2003-2004, LUGFi
2009, Marc Lorber
-License: GFDL-1.1
+License: GFDL-1.1+
+
+Files: data/help/C/oregano/index.html
+ data/help/C/oregano/oregano.xml
+ data/help/es/oregano/oregano.xml
+ data/help/fr/oregano/oregano.xml
+Copyright: 2003-2006 LUGFi
+License: GFDL-1.1+
Files: debian/*
Copyright: 2000 Hugo van der Merwe <hugovdm@mail.com>
@@ -36,6 +31,7 @@ Copyright: 2000 Hugo van der Merwe <hugovdm@mail.com>
2018 Ruben Undheim <rubund@debian.org>
License: GPL-2+
+
License: GPL-2+
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -50,7 +46,7 @@ License: GPL-2+
The complete text of the GNU General Public License version 2
can be found in "/usr/share/common-licenses/GPL-2".
-License: GFDL-1.1
+License: GFDL-1.1+
Permission is granted to copy, distribute and/or modify this
document under the terms of the GNU Free Documentation
License (GFDL), Version 1.1 or any later version published
diff --git a/debian/patches/0003-Remove-Encoding-field-in-desktop-file.patch b/debian/patches/0003-Remove-Encoding-field-in-desktop-file.patch
new file mode 100644
index 0000000..e3a0d3e
--- /dev/null
+++ b/debian/patches/0003-Remove-Encoding-field-in-desktop-file.patch
@@ -0,0 +1,19 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Sat, 13 Oct 2018 12:26:16 +0200
+Subject: Remove Encoding field in desktop file
+
+---
+ data/oregano.desktop.in | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/data/oregano.desktop.in b/data/oregano.desktop.in
+index 1b3c448..8d050fa 100644
+--- a/data/oregano.desktop.in
++++ b/data/oregano.desktop.in
+@@ -8,6 +8,5 @@ Terminal=false
+ X-MultipleArgs=false
+ Type=Application
+ Categories=GTK;Science;Education;Physics;
+-Encoding=UTF-8
+ StartupNotify=true
+ MimeType=application/x-oregano;
diff --git a/debian/patches/0004-Spelling-fixes.patch b/debian/patches/0004-Spelling-fixes.patch
new file mode 100644
index 0000000..e282240
--- /dev/null
+++ b/debian/patches/0004-Spelling-fixes.patch
@@ -0,0 +1,44 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Sat, 13 Oct 2018 12:27:02 +0200
+Subject: Spelling fixes
+
+---
+ src/netlist-editor.c | 2 +-
+ src/schematic-view.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/netlist-editor.c b/src/netlist-editor.c
+index 25352f5..6ff011b 100644
+--- a/src/netlist-editor.c
++++ b/src/netlist-editor.c
+@@ -322,7 +322,7 @@ NetlistEditor *netlist_editor_new_from_schematic_view (SchematicView *sv)
+ _ ("Could not create a netlist"), e);
+ } else {
+ log_append_error (schematic_get_log_store (sm), "Netlist",
+- _ ("Unexpected error occured"), e);
++ _ ("Unexpected error occurred"), e);
+ }
+ g_clear_error (&e);
+ return NULL;
+diff --git a/src/schematic-view.c b/src/schematic-view.c
+index f1cf234..ae48197 100644
+--- a/src/schematic-view.c
++++ b/src/schematic-view.c
+@@ -716,7 +716,7 @@ static void show_label_cmd (GtkToggleAction *toggle, SchematicView *sv)
+ _ ("Could not create a netlist."), e);
+ } else {
+ log_append_error (schematic_get_log_store (sm), _ ("SchematicView"),
+- _ ("Unexpect failure occured."), e);
++ _ ("Unexpect failure occurred."), e);
+ }
+ g_clear_error (&e);
+ return;
+@@ -871,7 +871,7 @@ static void netlist_cmd (GtkWidget *widget, SchematicView *sv)
+ _ ("Could not create a netlist."), e);
+ } else {
+ log_append_error (schematic_get_log_store (sm), _ ("SchematicView"),
+- _ ("Unexpect failure occured."), e);
++ _ ("Unexpect failure occurred."), e);
+ }
+ g_clear_error (&e);
+ return;
diff --git a/debian/patches/series b/debian/patches/series
index 8275374..774653d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,4 @@
clang_FTBFS_Wreturn-type.patch
0007-Update-russian-translation.patch
+0003-Remove-Encoding-field-in-desktop-file.patch
+0004-Spelling-fixes.patch