summaryrefslogtreecommitdiff
path: root/src/engines/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/engines/Makefile.am')
-rw-r--r--src/engines/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/engines/Makefile.am b/src/engines/Makefile.am
new file mode 100644
index 0000000..ccdf011
--- /dev/null
+++ b/src/engines/Makefile.am
@@ -0,0 +1,20 @@
+oreganodir = $(datadir)/oregano
+INCLUDES = \
+ $(OREGANO_CFLAGS) -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/model -I$(top_srcdir)/src/sheet \
+ -DOREGANO_XMLDIR=\""$(oreganodir)/xml"\" \
+ -DOREGANO_LIBRARYDIR=\""$(oreganodir)/libraries"\" \
+ -DOREGANO_MODELDIR=\""$(oreganodir)/models"\"
+
+noinst_LIBRARIES = libengines.a
+libengines_a_SOURCES = \
+ engine.c \
+ engine.h \
+ gnucap.c \
+ gnucap.h \
+ netlist.c \
+ netlist.h \
+ ngspice.c \
+ ngspice.h
+
+libengines_a_LIBADD = libengines.a