summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
authorSébastien Delafond <sdelafond@gmail.com>2014-07-13 13:35:27 +0200
committerSébastien Delafond <sdelafond@gmail.com>2014-07-13 13:35:27 +0200
commite32a45ed36d6000db4b39171149072d11b77af72 (patch)
treeb5f4a7d43022c08c3298e82b3e9fc50f68be660f /mk
parent7697fa4daf3ec84f85711a84035d8f0224afd4e3 (diff)
Imported Upstream version 8.0.7
Diffstat (limited to 'mk')
-rw-r--r--mk/default.mk13
-rw-r--r--mk/org-fixup.el21
-rw-r--r--mk/targets.mk1
-rw-r--r--mk/version.mk4
4 files changed, 21 insertions, 18 deletions
diff --git a/mk/default.mk b/mk/default.mk
index 3e1c550..1bafecb 100644
--- a/mk/default.mk
+++ b/mk/default.mk
@@ -24,7 +24,7 @@ infodir = $(prefix)/info
# Define if you want to include some (or all) files from contrib/lisp
# just the filename please (no path prefix, no .el suffix), maybe with globbing
-#ORG_ADD_CONTRIB = org-e-* org-md org-export # e.g. the new exporter
+#ORG_ADD_CONTRIB = ox-* # e.g. the contributed exporter
# Where to create temporary files for the testsuite
# respect TMPDIR if it is already defined in the environment
@@ -56,7 +56,7 @@ BTEST = $(BATCH) \
--eval '(add-to-list '"'"'load-path "./lisp")' \
--eval '(add-to-list '"'"'load-path "./testing")' \
$(BTEST_POST) \
- -l org-install.el \
+ -l org-loaddefs.el \
-l testing/org-test.el \
$(foreach ob-lang,$(BTEST_OB_LANGUAGES),$(req-ob-lang)) \
$(foreach req,$(BTEST_EXTRA),$(req-extra)) \
@@ -65,7 +65,8 @@ BTEST = $(BATCH) \
# Using emacs in batch mode.
# BATCH = $(EMACS) -batch -vanilla # XEmacs
-BATCH = $(EMACS) -batch -Q
+BATCH = $(EMACS) -batch -Q \
+ --eval '(setq vc-handled-backends nil)'
# Emacs must be started in toplevel directory
BATCHO = $(BATCH) \
@@ -81,17 +82,17 @@ MAKE_LOCAL_MK = $(BATCHO) \
BATCHL = $(BATCH) \
--eval '(add-to-list '"'"'load-path ".")'
-# How to generate org-install.el
+# How to generate org-loaddefs.el
MAKE_ORG_INSTALL = $(BATCHL) \
--eval '(load "org-compat.el")' \
--eval '(load "../mk/org-fixup.el")' \
- --eval '(org-make-org-install)'
+ --eval '(org-make-org-loaddefs)'
# How to generate org-version.el
MAKE_ORG_VERSION = $(BATCHL) \
--eval '(load "org-compat.el")' \
--eval '(load "../mk/org-fixup.el")' \
- --eval '(org-make-org-version "$(ORGVERSION)" "$(GITVERSION)" "$(datadir)")'
+ --eval '(org-make-org-version "$(ORGVERSION)" "$(GITVERSION)" "'$(datadir)'")'
# How to byte-compile the whole source directory
ELCDIR = $(BATCHL) \
diff --git a/mk/org-fixup.el b/mk/org-fixup.el
index 80439a9..aa7ff09 100644
--- a/mk/org-fixup.el
+++ b/mk/org-fixup.el
@@ -52,7 +52,7 @@ the Git work tree)."
(let ((org-git-version \"" org-git-version "\"))
org-git-version))
;;;\#\#\#autoload
-\(defconst org-odt-data-dir \"" odt-dir "\"
+\(defvar org-odt-data-dir \"" odt-dir "\"
\"The location of ODT styles.\")
\f\n\(provide 'org-version\)
\f\n;; Local Variables:\n;; version-control: never
@@ -61,26 +61,27 @@ the Git work tree)."
(toggle-read-only 0)
(write-file "org-version.el")))
-(defun org-make-org-install ()
- "Make the file org-install.el in the current directory.
+(defun org-make-org-loaddefs ()
+ "Make the file org-loaddefs.el in the current directory.
This function is internally used by the build system and should
be used by foreign build systems or installers to produce this
file in the installation directory of org-mode. Org will not
work correctly if this file is not up-to-date."
(with-temp-buffer
- (set-visited-file-name "org-install.el")
- (insert ";;; org-install.el --- autogenerated file, do not edit\n;;\n;;; Code:\n")
- (let ((files (directory-files default-directory nil "^\\(org\\|ob\\)\\(-.*\\)?\\.el$")))
+ (set-visited-file-name "org-loaddefs.el")
+ (insert ";;; org-loaddefs.el --- autogenerated file, do not edit\n;;\n;;; Code:\n")
+ (let ((files (directory-files default-directory
+ nil "^\\(org\\|ob\\|ox\\)\\(-.*\\)?\\.el$")))
(mapc (lambda (f) (generate-file-autoloads f)) files))
- (insert "\f\n(provide 'org-install)\n")
+ (insert "\f\n(provide 'org-loaddefs)\n")
(insert "\f\n;; Local Variables:\n;; version-control: never\n")
(insert ";; no-byte-compile: t\n;; no-update-autoloads: t\n")
- (insert ";; coding: utf-8\n;; End:\n;;; org-install.el ends here\n")
+ (insert ";; coding: utf-8\n;; End:\n;;; org-loaddefs.el ends here\n")
(toggle-read-only 0)
(save-buffer)))
(defun org-make-autoloads (&optional compile force)
- "Make the files org-install and org-version.el in the install directory.
+ "Make the files org-loaddefs.el and org-version.el in the install directory.
Finds the install directory by looking for library \"org\".
Optionally byte-compile lisp files in the install directory or
force re-compilation. This function is provided for easier
@@ -96,7 +97,7 @@ manual install when the build system can't be used."
(cd dirlisp)
(org-fixup)
(org-make-org-version (org-release) (org-git-version) dirodt)
- (org-make-org-install)
+ (org-make-org-loaddefs)
(when compile (byte-recompile-directory dirlisp 0 force)))
(cd origin))))
diff --git a/mk/targets.mk b/mk/targets.mk
index 4a9ee60..aef11eb 100644
--- a/mk/targets.mk
+++ b/mk/targets.mk
@@ -102,6 +102,7 @@ ifeq ($(TEST_NO_AUTOCLEAN),) # define this variable to leave $(testdir) around f
$(MAKE) cleantest
endif
+up0:: cleanaddcontrib
up0 up1 up2::
git remote update
git pull
diff --git a/mk/version.mk b/mk/version.mk
index 0d9c7af..f24ea79 100644
--- a/mk/version.mk
+++ b/mk/version.mk
@@ -1,2 +1,2 @@
-ORGVERSION ?= 7.9.2
-GITVERSION ?= 7.9.2-dist
+ORGVERSION ?= 8.0.7
+GITVERSION ?= 8.0.7-dist