summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoachim Breitner <nomeata@debian.org>2009-11-17 11:10:18 +0100
committerAndrej Shadura <andrewsh@debian.org>2019-01-07 13:03:17 +0100
commitb253682239cdbb1083b0b84fa130b496cb8f7c4c (patch)
tree74efe14a8c62ffe0c2b8164091804e8d43bda838
parent0c51c01876e24f96bbcf82d7472a74cd5ff78cff (diff)
Import Debian changes 0.7.0-10
osdsh (0.7.0-10) unstable; urgency=low * osdctl still hangs while trying to write to osdsh fifo (Closes: #432397). Thanks to Peter Colberg <peterco@gmx.net> for the patch! * Fix "FTBFS with binutils-gold" by removing HTML encoded dash from Makefile (WTF?) (Closes: #555874)
-rw-r--r--debian/changelog9
-rw-r--r--debian/control4
-rw-r--r--debian/copyright2
-rw-r--r--debian/patches/00list2
-rw-r--r--debian/patches/10-osdsh-create-fifo-before-fork.dpatch45
-rw-r--r--debian/patches/11-fix-binutils-gold.dpatch19
6 files changed, 78 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e5ea73e..29330ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+osdsh (0.7.0-10) unstable; urgency=low
+
+ * osdctl still hangs while trying to write to osdsh fifo (Closes:
+ #432397). Thanks to Peter Colberg <peterco@gmx.net> for the patch!
+ * Fix "FTBFS with binutils-gold" by removing HTML encoded dash from Makefile
+ (WTF?) (Closes: #555874)
+
+ -- Joachim Breitner <nomeata@debian.org> Tue, 17 Nov 2009 11:10:18 +0100
+
osdsh (0.7.0-9) unstable; urgency=low
* fixes: osdsh displays part of previous messages (Closes: #301229)
diff --git a/debian/control b/debian/control
index 31847f6..5c7463c 100644
--- a/debian/control
+++ b/debian/control
@@ -7,9 +7,9 @@ Standards-Version: 3.7.2
Package: osdsh
Architecture: any
-Depends: tk8.4 | wish, ${shlibs:Depends} ${misc:Depends}
+Depends: tk8.4 | wish, ${shlibs:Depends}, ${misc:Depends}
Description: Overlays your screen with various system information
- OSDsh is a a little program that overlays system information using
+ OSDsh is a little program that overlays system information using
the XOSD library. OSDsh was originally based on osdd and provides
features like:
.
diff --git a/debian/copyright b/debian/copyright
index 68b6bcc..69f247a 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -21,5 +21,5 @@ Copyright: 2002 Lord Darth Moultak
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
diff --git a/debian/patches/00list b/debian/patches/00list
index 1a339c9..6f8c831 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -7,3 +7,5 @@
07-compile-with-rdynamic-for-powerpc
08-strn-comments-fix
09-process-running-checks
+10-osdsh-create-fifo-before-fork
+11-fix-binutils-gold.dpatch
diff --git a/debian/patches/10-osdsh-create-fifo-before-fork.dpatch b/debian/patches/10-osdsh-create-fifo-before-fork.dpatch
new file mode 100644
index 0000000..089b950
--- /dev/null
+++ b/debian/patches/10-osdsh-create-fifo-before-fork.dpatch
@@ -0,0 +1,45 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 10-osdsh-create-fifo-before-fork.dpatch by Peter Colberg <peterco@gmx.net>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad osdsh-0.7.0~/src/osdsh/controlsh.c osdsh-0.7.0/src/osdsh/controlsh.c
+--- osdsh-0.7.0~/src/osdsh/controlsh.c 2007-01-12 13:40:21.000000000 +0100
++++ osdsh-0.7.0/src/osdsh/controlsh.c 2007-01-12 13:40:21.000000000 +0100
+@@ -210,10 +210,6 @@
+ initialize_osd(&settings);
+ load_basic_plugins();
+
+- /* create the fifo file*/
+- unlink(fifo_file);
+- umask(0);
+- mknod(fifo_file, S_IFIFO|0600, 0);
+ /*open and read the fifo*/
+ while (settings.displaying) {
+ fp = fopen(fifo_file, "r");
+diff -urNad osdsh-0.7.0~/src/osdsh/osdsh.c osdsh-0.7.0/src/osdsh/osdsh.c
+--- osdsh-0.7.0~/src/osdsh/osdsh.c 2007-01-12 13:40:21.000000000 +0100
++++ osdsh-0.7.0/src/osdsh/osdsh.c 2007-01-12 13:42:49.000000000 +0100
+@@ -152,6 +152,7 @@
+
+ char pid_file[PATH_MAX+1];
+ FILE *fp;
++ char fifo_file[PATH_MAX +1];
+
+ set_defaults(&settings);
+ initialize_osd(&settings);
+@@ -169,6 +170,12 @@
+ pppset = mixerset = settings;
+ */
+
++ /* create the fifo file*/
++ sprintf(fifo_file, "%s.%d", OSD_FIFO_PATH, getuid());
++ unlink(fifo_file);
++ umask(0);
++ mknod(fifo_file, S_IFIFO|0600, 0);
++
+ if((childpid=fork())<0) {
+ perror("fork");
+ exit(1);
diff --git a/debian/patches/11-fix-binutils-gold.dpatch b/debian/patches/11-fix-binutils-gold.dpatch
new file mode 100644
index 0000000..90ed5aa
--- /dev/null
+++ b/debian/patches/11-fix-binutils-gold.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 11-fix-binutils-gold.dpatch by Joachim Breitner <nomeata@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad osdsh-0.7.0~/src/osdsh/Makefile osdsh-0.7.0/src/osdsh/Makefile
+--- osdsh-0.7.0~/src/osdsh/Makefile 2009-11-17 11:08:07.000000000 +0100
++++ osdsh-0.7.0/src/osdsh/Makefile 2009-11-17 11:08:07.000000000 +0100
+@@ -22,7 +22,7 @@
+
+ osdsh: $(OBJS)
+ gcc -c $(CFLAGS) $@.c
+- gcc $(CFLAGS) -o $@ osdsh.o $(OBJS) $(LIBS) &#8211;ldl
++ gcc $(CFLAGS) -o $@ osdsh.o $(OBJS) $(LIBS) -ldl
+
+ clean: libclean
+ rm -f osdsh