summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-10-02 08:25:23 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-10-02 08:25:23 +0200
commit1d54f550b0d0c1ebad303476003be45140ab763a (patch)
tree7e2fa73edbe0898e92ab2f17f442c91d676fce0d
parent9bd6a9553e85b39e4bb93fdb01391e0f7f278ffd (diff)
Improvements in d/rules
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c4d783a..0e94dc8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,9 @@
#!/usr/bin/make -f
#export DH_VERBOSE=1
+
+include /usr/share/dpkg/pkg-info.mk
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
arch = $(shell dpkg-architecture -qDEB_BUILD_ARCH)
@@ -8,10 +11,16 @@ arch = $(shell dpkg-architecture -qDEB_BUILD_ARCH)
%:
dh $@ --with autoreconf --fail-missing
+
+override_dh_autoreconf:
+ echo $(DEB_VERSION_UPSTREAM) > .tarball-version
+ dh_autoreconf
+
override_dh_clean:
dh_clean
$(RM) tests/package.m4
$(RM) test/testsuite
+ $(RM) .tarball-version
# Print test results in case of a failure
override_dh_auto_test:
@@ -28,3 +37,5 @@ override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false) \
fi
+override_dh_installsystemd:
+ dh_installsystemd --no-enable --no-start