summaryrefslogtreecommitdiff
path: root/Linux-PAM/examples
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 12:47:05 -0800
committerSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 12:47:05 -0800
commit4c51da22e068907adb7857d50f5109a467c94d7c (patch)
treebecf5fbae5dfcbe8896355f59042dc8eaefa7f37 /Linux-PAM/examples
parentefd31890b5ed496a5a00c08a262da240e66a4ddc (diff)
parentab9e8ba11f464fc083fc65a0bc695d60ebc86f3e (diff)
New upstream version 0.79
Diffstat (limited to 'Linux-PAM/examples')
-rw-r--r--Linux-PAM/examples/Makefile2
-rw-r--r--Linux-PAM/examples/blank.c2
-rw-r--r--Linux-PAM/examples/check_user.c2
-rw-r--r--Linux-PAM/examples/xsh.c8
4 files changed, 7 insertions, 7 deletions
diff --git a/Linux-PAM/examples/Makefile b/Linux-PAM/examples/Makefile
index a55f1d21..3ffea528 100644
--- a/Linux-PAM/examples/Makefile
+++ b/Linux-PAM/examples/Makefile
@@ -1,5 +1,5 @@
#
-# $Id: Makefile,v 1.1.1.2 2002/09/15 20:08:35 hartmans Exp $
+# $Id: Makefile,v 1.6 2002/06/27 04:04:54 agmorgan Exp $
#
include ../Make.Rules
diff --git a/Linux-PAM/examples/blank.c b/Linux-PAM/examples/blank.c
index e4129b4b..20896b5c 100644
--- a/Linux-PAM/examples/blank.c
+++ b/Linux-PAM/examples/blank.c
@@ -1,5 +1,5 @@
/*
- * $Id: blank.c,v 1.1.1.1 2001/04/29 04:17:04 hartmans Exp $
+ * $Id: blank.c,v 1.2 2000/12/04 19:02:33 baggins Exp $
*/
/* Andrew Morgan (morgan@parc.power.net) -- a self contained `blank'
diff --git a/Linux-PAM/examples/check_user.c b/Linux-PAM/examples/check_user.c
index 295d6715..cb539c4e 100644
--- a/Linux-PAM/examples/check_user.c
+++ b/Linux-PAM/examples/check_user.c
@@ -1,5 +1,5 @@
/*
- $Id: check_user.c,v 1.1.1.1 2001/04/29 04:17:04 hartmans Exp $
+ $Id: check_user.c,v 1.2 2000/12/04 19:02:33 baggins Exp $
This program was contributed by Shane Watts <shane@icarus.bofh.asn.au>
slight modifications by AGM.
diff --git a/Linux-PAM/examples/xsh.c b/Linux-PAM/examples/xsh.c
index 0e092402..3f5246f5 100644
--- a/Linux-PAM/examples/xsh.c
+++ b/Linux-PAM/examples/xsh.c
@@ -1,18 +1,18 @@
/*
- * $Id: xsh.c,v 1.1.1.2 2002/09/15 20:08:35 hartmans Exp $
+ * $Id: xsh.c,v 1.7 2004/09/24 09:18:21 kukuk Exp $
*/
/* Andrew Morgan (morgan@kernel.org) -- an example application
* that invokes a shell, based on blank.c */
+#include <security/_pam_aconf.h>
+
#include <stdio.h>
#include <stdlib.h>
#include <security/pam_appl.h>
#include <security/pam_misc.h>
-#include <security/_pam_aconf.h>
-
#include <pwd.h>
#include <sys/types.h>
#include <unistd.h>
@@ -155,7 +155,7 @@ int main(int argc, char **argv)
fprintf(stderr,"%s: problem closing a session\n",argv[0]);
break;
}
-
+
/* `0' could be as above */
retcode = pam_setcred(pamh, PAM_DELETE_CRED);
bail_out(pamh,0,retcode,"pam_setcred");