summaryrefslogtreecommitdiff
path: root/Linux-PAM/modules/pam_keyinit
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 16:09:38 -0800
committerSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 16:09:38 -0800
commit03398c56c56ed427818d2ce879d45d1009f7d46b (patch)
tree9a7bc0d7d15ac988ac9ad31ad18a769030faced7 /Linux-PAM/modules/pam_keyinit
parente78677298d54010c3a62b932baefdae152fd0fed (diff)
parent281e859131adad49301befbc50cfc5cd282c6937 (diff)
merge upstream version 0.99.9.0
Diffstat (limited to 'Linux-PAM/modules/pam_keyinit')
-rw-r--r--Linux-PAM/modules/pam_keyinit/Makefile.am4
-rw-r--r--Linux-PAM/modules/pam_keyinit/Makefile.in7
2 files changed, 6 insertions, 5 deletions
diff --git a/Linux-PAM/modules/pam_keyinit/Makefile.am b/Linux-PAM/modules/pam_keyinit/Makefile.am
index 49e34d75..5039705a 100644
--- a/Linux-PAM/modules/pam_keyinit/Makefile.am
+++ b/Linux-PAM/modules/pam_keyinit/Makefile.am
@@ -22,8 +22,7 @@ securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam
+AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
@@ -31,3 +30,4 @@ endif
if HAVE_KEY_MANAGEMENT
securelib_LTLIBRARIES = pam_keyinit.la
endif
+pam_keyinit_la_LIBADD = -L$(top_builddir)/libpam -lpam
diff --git a/Linux-PAM/modules/pam_keyinit/Makefile.in b/Linux-PAM/modules/pam_keyinit/Makefile.in
index 401c09b6..5ea2133d 100644
--- a/Linux-PAM/modules/pam_keyinit/Makefile.in
+++ b/Linux-PAM/modules/pam_keyinit/Makefile.in
@@ -64,7 +64,7 @@ am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(securelibdir)" "$(DESTDIR)$(man8dir)"
securelibLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(securelib_LTLIBRARIES)
-pam_keyinit_la_LIBADD =
+pam_keyinit_la_DEPENDENCIES =
pam_keyinit_la_SOURCES = pam_keyinit.c
pam_keyinit_la_OBJECTS = pam_keyinit.lo
@HAVE_KEY_MANAGEMENT_TRUE@am_pam_keyinit_la_rpath = -rpath \
@@ -177,6 +177,7 @@ POSUB = @POSUB@
RANLIB = @RANLIB@
SCONFIGDIR = @SCONFIGDIR@
SECUREDIR = @SECUREDIR@
+SED = @SED@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
@@ -255,9 +256,9 @@ XMLS = README.xml pam_keyinit.8.xml
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam $(am__append_1)
+AM_LDFLAGS = -no-undefined -avoid-version -module $(am__append_1)
@HAVE_KEY_MANAGEMENT_TRUE@securelib_LTLIBRARIES = pam_keyinit.la
+pam_keyinit_la_LIBADD = -L$(top_builddir)/libpam -lpam
all: all-am
.SUFFIXES: