summaryrefslogtreecommitdiff
path: root/Linux-PAM/modules/pam_umask
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 16:09:38 -0800
committerSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 16:09:38 -0800
commit03398c56c56ed427818d2ce879d45d1009f7d46b (patch)
tree9a7bc0d7d15ac988ac9ad31ad18a769030faced7 /Linux-PAM/modules/pam_umask
parente78677298d54010c3a62b932baefdae152fd0fed (diff)
parent281e859131adad49301befbc50cfc5cd282c6937 (diff)
merge upstream version 0.99.9.0
Diffstat (limited to 'Linux-PAM/modules/pam_umask')
-rw-r--r--Linux-PAM/modules/pam_umask/Makefile.am4
-rw-r--r--Linux-PAM/modules/pam_umask/Makefile.in7
2 files changed, 6 insertions, 5 deletions
diff --git a/Linux-PAM/modules/pam_umask/Makefile.am b/Linux-PAM/modules/pam_umask/Makefile.am
index 56fa63b4..53a666aa 100644
--- a/Linux-PAM/modules/pam_umask/Makefile.am
+++ b/Linux-PAM/modules/pam_umask/Makefile.am
@@ -16,13 +16,13 @@ securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam
+AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
securelib_LTLIBRARIES = pam_umask.la
+pam_umask_la_LIBADD = -L$(top_builddir)/libpam -lpam
if ENABLE_REGENERATE_MAN
noinst_DATA = README
diff --git a/Linux-PAM/modules/pam_umask/Makefile.in b/Linux-PAM/modules/pam_umask/Makefile.in
index 45dd9509..54e8868f 100644
--- a/Linux-PAM/modules/pam_umask/Makefile.in
+++ b/Linux-PAM/modules/pam_umask/Makefile.in
@@ -64,7 +64,7 @@ am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(securelibdir)" "$(DESTDIR)$(man8dir)"
securelibLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(securelib_LTLIBRARIES)
-pam_umask_la_LIBADD =
+pam_umask_la_DEPENDENCIES =
pam_umask_la_SOURCES = pam_umask.c
pam_umask_la_OBJECTS = pam_umask.lo
DEFAULT_INCLUDES = -I. -I$(top_builddir)@am__isrc@
@@ -175,6 +175,7 @@ POSUB = @POSUB@
RANLIB = @RANLIB@
SCONFIGDIR = @SCONFIGDIR@
SECUREDIR = @SECUREDIR@
+SED = @SED@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
@@ -252,9 +253,9 @@ TESTS = tst-pam_umask
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam $(am__append_1)
+AM_LDFLAGS = -no-undefined -avoid-version -module $(am__append_1)
securelib_LTLIBRARIES = pam_umask.la
+pam_umask_la_LIBADD = -L$(top_builddir)/libpam -lpam
@ENABLE_REGENERATE_MAN_TRUE@noinst_DATA = README
all: all-am