summaryrefslogtreecommitdiff
path: root/Make.xml.rules
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-01-30 21:58:23 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-01-30 21:58:23 +0000
commit41e81d7048ab8a9bf9730212f7f5ea18b051d2dc (patch)
treec21605e974c2e0832181361ae7a9dbe36bbf4eb0 /Make.xml.rules
parentc1e45ad7ff6ec3e26a535c128eff0f34fd637111 (diff)
Relevant BUGIDs: none
Purpose of commit: bugfix/cleanup Commit summary: --------------- Instead of duplicating the xml rules for every directory again, include them from the top level one. 2006-01-30 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_exec/pam_exec.8.xml: Fix syntax of Return Value section. * modules/pam_exec/Makefile.am: Include Make.xml.rules. * Make.xml.rules: New.
Diffstat (limited to 'Make.xml.rules')
-rw-r--r--Make.xml.rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/Make.xml.rules b/Make.xml.rules
new file mode 100644
index 00000000..f6512aae
--- /dev/null
+++ b/Make.xml.rules
@@ -0,0 +1,22 @@
+#
+# Copyright (c) 2006 Thorsten Kukuk <kukuk@thkukuk.de>
+#
+
+%.1: %.1.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.3: %.3.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.5: %.5.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.8: %.8.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+#CLEANFILES += $(man_MANS)
+