summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2011-10-27 14:55:55 +0000
committerDmitry V. Levin <ldv@altlinux.org>2011-10-27 14:55:55 +0000
commit790ffe6e011bc7721d687ab4ac6419eb18c72624 (patch)
treed0de67369e5bc22c291571741fa69d10a0c6f1a6 /Makefile.am
parenta03bf70cc3c6fc0992dc6a8e56b10649e56bf553 (diff)
Generate ChangeLog from git log
* .gitignore: Add ChangeLog * ChangeLog: Rename to ChangeLog-CVS. * Makefile.am (gen-changelog): New rule. (dist-hook, .PHONY): Depend on it. (EXTRA_DIST): Add ChangeLog-CVS. * README-hacking: New file. * gitlog-to-changelog: Import from gnulib. * autogen.sh: Create empty ChangeLog file to make automake strictness check happy. Use automated "autoreconf -fiv" instead of manual invocations of various autotools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d41b87d..4384758b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,7 @@ endif
CLEANFILES = *~
EXTRA_DIST = config.rpath mkinstalldirs pgp.keys.asc CHANGELOG \
- Copyright Make.xml.rules
+ ChangeLog-CVS Copyright Make.xml.rules
ACLOCAL_AMFLAGS = -I m4
@@ -35,3 +35,18 @@ xtests:
make -C xtests xtests
.PHONY: xtests
+
+gen_changelog_start_date = 2011-10-26
+gen-ChangeLog:
+ if test -d .git; then \
+ ( $(top_srcdir)/gitlog-to-changelog --append-dot \
+ --since=$(gen_changelog_start_date) && \
+ echo && echo && \
+ echo 'See ChangeLog-CVS for earlier changes.' \
+ ) > $(distdir)/ChangeLog.new && \
+ rm -f $(distdir)/ChangeLog && \
+ mv $(distdir)/ChangeLog.new $(distdir)/ChangeLog; \
+ fi
+
+dist-hook: gen-ChangeLog
+.PHONY: gen-ChangeLog