summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2002-05-29 06:35:46 +0000
committerAndrew G. Morgan <morgan@kernel.org>2002-05-29 06:35:46 +0000
commite509c5af6f70eb3cfd846004b82caaca24fd4a3b (patch)
treefe9859716e1120d88c1d3b6bf24aa1617c138332 /conf
parent62f3574062ed05e9afd512028994bd17639c0b2f (diff)
Relevant BUGIDs: 491466
Purpose of commit: cleanup Commit summary: --------------- These were all suggestions from the OS X patch provided by Luke Howard. There is another proposed patch for OS X support which promises to be a little cleaner with the heavy stuff, so I am committing these simple changes now, with the intention of moving to the other patch for the big stuff (see 534205).
Diffstat (limited to 'conf')
-rw-r--r--conf/pam_conv1/Makefile7
-rw-r--r--conf/pam_conv1/pam_conv.y3
2 files changed, 8 insertions, 2 deletions
diff --git a/conf/pam_conv1/Makefile b/conf/pam_conv1/Makefile
index 7691dc31..2fda767e 100644
--- a/conf/pam_conv1/Makefile
+++ b/conf/pam_conv1/Makefile
@@ -1,4 +1,9 @@
#
+# $Id$
+#
+
+include ../../Make.Rules
+
#
ifeq ($(OS),solaris)
@@ -16,7 +21,7 @@ else
all: pam_conv1
pam_conv1: pam_conv.tab.c lex.yy.c
- $(CC) -o pam_conv1 pam_conv.tab.c -lfl
+ $(CC) -o pam_conv1 pam_conv.tab.c $(LINK_LIBLEX)
pam_conv.tab.c: pam_conv.y lex.yy.c
bison pam_conv.y
diff --git a/conf/pam_conv1/pam_conv.y b/conf/pam_conv1/pam_conv.y
index 18bedccf..f42b634e 100644
--- a/conf/pam_conv1/pam_conv.y
+++ b/conf/pam_conv1/pam_conv.y
@@ -193,11 +193,12 @@ void yyerror(const char *format, ...)
fprintf(stderr, "\n");
}
-void main()
+int main(int argc, char *argv[])
{
if (mkdir(PAM_D, PAM_D_MODE) != 0) {
yyerror(PAM_D " already exists.. aborting");
exit(1);
}
yyparse();
+ exit(0);
}