summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-05-08 05:02:50 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-05-08 05:02:50 +0000
commit1ffe510887d0e16782849bf364087fad844ff744 (patch)
treed7551546c128d355187f4885276a013605da2caa /configure.in
parent7626d42b8d9ae4ea90f731e79ce8a9acce1ca8c2 (diff)
Relevant BUGIDs: 416229
Purpose of commit: cleanup Commit summary: --------------- A little closer to supporting AIX. These changes are not all of the suggested changes in the bug report that I will close as a result of this checkin, but they are all the changes that I feel happy making right now. I've avoided some of the more gratutitous changes, hoping that the submitter will reevaluate what they need in the light of what I have committed here.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 38 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 3e7287ff..99ed8d99 100644
--- a/configure.in
+++ b/configure.in
@@ -36,7 +36,6 @@ AC_SUBST(OS)
SHLIBMODE=755 ; AC_SUBST(SHLIBMODE)
dnl These are most likely platform specific - I think HPUX differs
-DYNTYPE=so ; AC_SUBST(DYNTYPE)
USESONAME=yes ; AC_SUBST(USESONAME)
SOSWITCH=-soname ; AC_SUBST(SOSWITCH)
NEEDSONAME=no ; AC_SUBST(NEEDSONAME)
@@ -45,7 +44,12 @@ LDCONFIG=/sbin/ldconfig ; AC_SUBST(LDCONFIG)
dnl ### Should enable this INSTALL detection.
dnl ### Would need to distribute GNU's config.guess and config.sub
dnl AC_PROG_INSTALL
-INSTALL=/usr/bin/install ; AC_SUBST(INSTALL)
+if test "$OS" = "aix"; then
+ INSTALL=/usr/ucb/install -c
+else
+ INSTALL=/usr/bin/install
+fi
+AC_SUBST(INSTALL)
dnl Checks for programs.
AC_PROG_CC
@@ -265,26 +269,46 @@ GCC_WARNINGS="-Wall -Wwrite-strings \
-Wnested-externs -Winline -Wshadow"
if test "$GCC" = yes; then
- OS_CFLAGS=""
### May need per-OS attention
### Example: -D_POSIX_SOURCE: needed on Linux but harms Solaris.
case $OS in
linux)
OS_CFLAGS="-ansi -D_POSIX_SOURCE -pedantic"
+ LD_D="gcc -shared -Xlinker -x"
+ WARNINGS="$GCC_WARNINGS"
+ PIC="-fPIC"
+ DYNTYPE=so
+ LD=ld
+ LD_L="$LD -x -shared"
+ RANLIB=ranlib
+ STRIP=strip
+ CC_STATIC="-Xlinker -export-dynamic"
;;
sunos)
OS_CFLAGS="-ansi -pedantic"
+ LD_D="gcc -shared -Xlinker -x"
+ WARNINGS="$GCC_WARNINGS"
+ PIC="-fPIC"
+ DYNTYPE=so
+ LD=ld
+ LD_L="$LD -x -shared"
+ RANLIB=ranlib
+ STRIP=strip
+ CC_STATIC="-Xlinker -export-dynamic"
+ ;;
+ aix)
+ OS_CFLAGS=""
+ DYNTYPE=lo
+ LD=ld
+ LD_L=ld -bexpall -bM:SRE -bnoentry
+ LD_D="$LD_L"
+ RANLIB=ranlib
+ STRIP=strip
+ ;;
+ *)
+ OS_CFLAGS=""
;;
esac
- WARNINGS="$GCC_WARNINGS"
- PIC="-fPIC"
-#can/should we use LD=gcc ???
- LD=ld
- LD_D="gcc -shared -Xlinker -x"
- LD_L="$LD -x -shared"
- RANLIB=ranlib
- STRIP=strip
- CC_STATIC="-Xlinker -export-dynamic"
else
###
### Non-gcc needs attention on per-OS basis
@@ -293,6 +317,7 @@ else
OS_CFLAGS=""
WARNINGS=""
PIC="-K pic"
+ DYNTYPE=so
LD=ld
LD_D="cc -z text -G -R."
LD_L="$LD_D"
@@ -301,6 +326,7 @@ else
CC_STATIC=
fi
+AC_SUBST(DYNTYPE)
AC_SUBST(OS_CFLAGS)
AC_SUBST(WARNINGS)
AC_SUBST(PIC)