summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2023-10-24 19:38:53 +0200
committerSteve Langasek <steve.langasek@canonical.com>2023-11-20 05:59:53 -0800
commit3a128a9b5db023be2710383a4a7dfe192788d7a3 (patch)
tree914d0fdd4ca14b5b1bd48d6d2186d4053ec4202e /debian/rules
parent71662fe5ed190d4c8fca3fe4554a13259a2b05d7 (diff)
Import Debian changes 1.5.2-9.1
pam (1.5.2-9.1) unstable; urgency=medium . * Non-maintainer upload acked by Sam Hartman. * Really fix quilt-related FTBFS: (Closes: #1054505) pam is a 3.0 (quilt) source package and has a .pc directory after unpack despite having no debian/patches. Even when setting QUILT_PATCH_DIR or QUILT_PATCHES, quilt is now mislead to using the non-existent debian/patches and this makes dh_quilt_unpatch fail, so we delete that directory unless it corresponds to the real debian/patches-applied that we want to be used.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 73819f0c..f4881680 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,6 +21,12 @@ dl = $(d)/local
%:
dh $@ --with quilt,autoreconf
+# Since this is a 3.0 (quilt) source package, it has a .pc directory pointing
+# to debian/patches after initial unpack. This misleads quilt and makes
+# dh_quilt_unpatch fail hard.
+execute_before_dh_quilt_unpatch:
+ if test "`cat .pc/.quilt_patches 2>/dev/null`" = debian/patches; then rm -Rf .pc; fi
+
# avoid libaudit-dev when bootstrapping
ifneq (,$(filter stage1,$(DEB_BUILD_PROFILES)))
CONFIGURE_OPTS += --disable-audit