summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2008-07-25 17:02:00 -0700
committerSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 17:01:53 -0800
commitbdb63761bcd55b3f01d653824c1f3990bbda45c0 (patch)
tree74d9a525fa627b1f9472fdc7f31e6220e17cd01b /debian/rules
parentffe5367d73e3627e46df9f4843f92b7dde590a6c (diff)
The password-changing helper functionality for SELinux systems has been
split out into a separate unix_update binary, so at long last we can change unix_chkpwd to be sgid shadow instead of suid root. Closes: #155583.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 89bff84f..ad9ccc9b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -137,7 +137,8 @@ binary-arch: install
dh_strip -a
dh_compress -a
dh_fixperms -a
- chmod 04755 $(d)/libpam-modules/sbin/unix_chkpwd
+ chmod 02755 $(d)/libpam-modules/sbin/unix_chkpwd
+ chgrp shadow $(d)/libpam-modules/sbin/unix_chkpwd
dh_makeshlibs -plibpam0g -V "libpam0g (>= 0.99.7.1)"
dh_installdeb -a
dh_shlibdeps -a -L libpam0g -l$(CURDIR)/debian/libpam0g/lib