summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2010-04-25 06:28:04 +0200
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:26:03 -0800
commitdc150f2311b6f2f6b7a92e723945f0d3b47e84c9 (patch)
tree06a4bc67a12ce9c1f9ba9b50971f6e35d0d05014 /debian
parentfbcc1cb3851fabef569ed1132fb13b9bedfa6041 (diff)
pam-auth-update: fix a bug in our handling of module options when the
module name contains digits, caused by a buggy regexp. :/ Partially addresses LP #369575.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/local/pam-auth-update2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b422b423..fadfde3e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+pam (1.1.1-3) UNRELEASED; urgency=low
+
+ * pam-auth-update: fix a bug in our handling of module options when the
+ module name contains digits, caused by a buggy regexp. :/ Partially
+ addresses LP #369575.
+
+ -- Steve Langasek <vorlon@debian.org> Sun, 25 Apr 2010 06:26:31 +0200
+
pam (1.1.1-2) unstable; urgency=low
* Document the new symbols added in 1.1.1 in debian/libpam0g.symbols, and
diff --git a/debian/local/pam-auth-update b/debian/local/pam-auth-update
index 1a1a452d..7f14982d 100755
--- a/debian/local/pam-auth-update
+++ b/debian/local/pam-auth-update
@@ -255,7 +255,7 @@ sub merge_one_line
$modline =~ s/end/$count/g;
if ($diff) {
my $mod = $modline;
- $mod =~ s/[0-9]+//g;
+ $mod =~ s/(\[[^0-9]*)[0-9]+(.*\])/$1$2/g;
$adds = \%{$diff->{'add'}{$mod}};
$removes = \%{$diff->{'remove'}{$mod}};
} else {