summaryrefslogtreecommitdiff
path: root/doc/specs/Makefile.am
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:55:23 +0100
committerTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:59:44 +0100
commit1781f0165c6f83601088f47681a05956ad9c21e1 (patch)
treefca2caff5fac43bad7f657f81c7a2a1b3df2ab62 /doc/specs/Makefile.am
parent73118592885eb3554eddb360d5f6ab65ee6e1c03 (diff)
Do not use CFLAGS for warning flags set from configure
To be able to set CFLAGS from make command-line but not to lose the warning flags. * configure.ac: Put warning flags to WARN_CFLAGS instead of CFLAGS. * */Makefile.am: Apply WARN_CFLAGS to AM_CFLAGS.
Diffstat (limited to 'doc/specs/Makefile.am')
-rw-r--r--doc/specs/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/specs/Makefile.am b/doc/specs/Makefile.am
index de20decd..58e14b38 100644
--- a/doc/specs/Makefile.am
+++ b/doc/specs/Makefile.am
@@ -16,7 +16,7 @@ CPPFLAGS = @BUILD_CPPFLAGS@
CFLAGS = @BUILD_CFLAGS@
LDFLAGS = @BUILD_LDFLAGS@
-padout_CFLAGS = -Wno-unused-function -Wno-sign-compare
+padout_CFLAGS = $(WARN_CFLAGS) -Wno-unused-function -Wno-sign-compare
BUILT_SOURCES = parse_y.h