summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:55:23 +0100
committerTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:59:44 +0100
commit1781f0165c6f83601088f47681a05956ad9c21e1 (patch)
treefca2caff5fac43bad7f657f81c7a2a1b3df2ab62 /examples
parent73118592885eb3554eddb360d5f6ab65ee6e1c03 (diff)
Do not use CFLAGS for warning flags set from configure
To be able to set CFLAGS from make command-line but not to lose the warning flags. * configure.ac: Put warning flags to WARN_CFLAGS instead of CFLAGS. * */Makefile.am: Apply WARN_CFLAGS to AM_CFLAGS.
Diffstat (limited to 'examples')
-rw-r--r--examples/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index ebec86d0..722ec686 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -7,7 +7,7 @@ CLEANFILES = *~
EXTRA_DIST = README
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
- -I$(top_srcdir)/libpam_misc/include
+ -I$(top_srcdir)/libpam_misc/include $(WARN_CFLAGS)
LDADD = $(top_builddir)/libpam/libpam.la \
$(top_builddir)/libpam_misc/libpam_misc.la