summaryrefslogtreecommitdiff
path: root/libpam/pam_private.h
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-01-22 07:36:54 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-01-22 07:36:54 +0000
commit5116bebb80ac7ee441c66b1a884d2653755dc4d9 (patch)
tree3099a4612f58dca3a23633d7a00da4283ad025a9 /libpam/pam_private.h
parentb1b9e62160a35087e006faa799c89431c76b4d89 (diff)
Relevant BUGIDs: none
Purpose of commit: bugfix Commit summary: --------------- Fix compiling of static version of shared libpam, libpamc and libpam_misc libraries without assuming "--enable-static-modules do not make the modules dynamically loadable". 2006-01-22 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Don't define PAM_DYNAMIC. * libpam/pam_handlers.c: Get ride of PAM_DYNAMIC, don't include pam_dynamic.h * libpam/pam_dynamic.c: Don't include pam_dynamic.h, exclude functions if we compile with PAM_STATIC. * libpam/pam_dynamic.h: Remove. * libpam/pam_private.h: Add function prototypes from pam_dynamic.h. * libpam/Makefile.am: Bump version number of libpam, remove pam_dynamic.h.
Diffstat (limited to 'libpam/pam_private.h')
-rw-r--r--libpam/pam_private.h9
1 files changed, 7 insertions, 2 deletions
diff --git a/libpam/pam_private.h b/libpam/pam_private.h
index 3d86b868..5ab0f8c5 100644
--- a/libpam/pam_private.h
+++ b/libpam/pam_private.h
@@ -219,8 +219,9 @@ void _pam_start_timer(pam_handle_t *pamh);
void _pam_await_timer(pam_handle_t *pamh, int status);
typedef void (*voidfunc(void))(void);
-#ifdef PAM_STATIC
+typedef int (*servicefn)(pam_handle_t *, int, int, char **);
+#ifdef PAM_STATIC
/* The next two in ../modules/_pam_static/pam_static.c */
/* Return pointer to data structure used to define a static module */
@@ -229,7 +230,11 @@ struct pam_module * _pam_open_static_handler(const char *path);
/* Return pointer to function requested from static module */
voidfunc *_pam_get_static_sym(struct pam_module *mod, const char *symname);
-
+#else
+void *_pam_dlopen (const char *mod_path);
+servicefn _pam_dlsym (void *handle, const char *symbol);
+void _pam_dlclose (void *handle);
+const char *_pam_dlerror (void);
#endif
/* For now we just use a stack and linear search for module data. */