summaryrefslogtreecommitdiff
path: root/libpamc
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:55:23 +0100
committerTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:59:44 +0100
commit1781f0165c6f83601088f47681a05956ad9c21e1 (patch)
treefca2caff5fac43bad7f657f81c7a2a1b3df2ab62 /libpamc
parent73118592885eb3554eddb360d5f6ab65ee6e1c03 (diff)
Do not use CFLAGS for warning flags set from configure
To be able to set CFLAGS from make command-line but not to lose the warning flags. * configure.ac: Put warning flags to WARN_CFLAGS instead of CFLAGS. * */Makefile.am: Apply WARN_CFLAGS to AM_CFLAGS.
Diffstat (limited to 'libpamc')
-rw-r--r--libpamc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libpamc/Makefile.am b/libpamc/Makefile.am
index 536e417a..85c9ce7f 100644
--- a/libpamc/Makefile.am
+++ b/libpamc/Makefile.am
@@ -12,7 +12,7 @@ include_HEADERS = include/security/pam_client.h
noinst_HEADERS = libpamc.h
-AM_CFLAGS=-I$(top_srcdir)/libpam/include -I$(srcdir)/include
+AM_CFLAGS=-I$(top_srcdir)/libpam/include -I$(srcdir)/include $(WARN_CFLAGS)
libpamc_la_LDFLAGS = -no-undefined -version-info 82:1:82
if HAVE_VERSIONING